It looks like the end-of-proof symbol is misaligned if multline* and \qedhere are used. Or am I just using them wrong?

 Only words here.
  A=form(u)la. \qedhere
  A=form(u)la.\\ with/many*lines \qedhere

enter image description here

Is there a way to fix this?

  • 2
    this is definitely a known issue, but you have turned up a previously unknown problem as well -- with equation* a spurious warning is issued. that has been added to our list. Mar 12, 2013 at 12:53

2 Answers 2


This seems to be a known issue; the log file for your example contains the following.

Package amsthm Warning: The \qedhere command may not work correctly here on input line 15.

I'm not aware of a fix, but there are others here who know much more about ams packages than I do. A workaround is


in place of \qedhere.

  • 1
    I checked, and I get that warning once for line 9 (where the \qedhere inside the equation* is) and twice for line 15 (where the one inside multline* is). Strange. Anyway, thanks for pointing this out; I use kile, and it did not display the warning for some reason. Mar 12, 2013 at 10:31
  • 4
    this workaround will do the right thing only when equation numbers are positioned on the right. also, it's necessary to suppress the non-"here" box with \renewcommand{\qedsymbol}{}; since a proof is a local group, this definition will not persist after \end{proof}. Mar 12, 2013 at 13:02
  • @barbarabeeton Another workaround is to "guess" the correct shift and do \let\myqedsymbol\qedsymbol \def\qedsymbol{\myqedsymbol\hspace*{-10pt}} \qedhere inside minipage*. It's a dirty solution, but it works; one just have to make sure that the output is correct.
    – yo'
    Jan 26, 2015 at 21:05

As mentioned in this answer and this one, amsthm should be loaded after `amsmath. I just tried by replacing




and it worked fine.

  • 1
    Thanks for the suggestion! On my machine, changing the order of the two packages results in the last tombstone being a little too far on the left, rather than on the right. So this change does something, but it does not fix the issue. Oct 25, 2020 at 18:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .