1

I am trying to render this mindmap but I am getting some artifacts. Can anyone tell why.

\documentclass{article}
\usepackage{pgfplots}
\usetikzlibrary{mindmap,trees, backgrounds}

\begin{document}
\section{Introduction}

\begin{figure}[h]
\makebox[\textwidth][c]{
\begin{tikzpicture}
%%%%%%%%%%%%%%% CANOPY STRUCTURE
  \path[mindmap,concept color=green!50!black, text=white]

    node[concept](struct) at (0,0){Canopy Structure}
            child[grow = -45, concept color = orange]{
            node[concept](light){Light Interception}
                    [clockwise from = 20]
                    child{node[concept](alb) {Shortwave albedo}}
                    child{node[concept](lw){Longwave Emissivity}}
                    child{node[concept](shade){Shading}}
                    }
        %----------------------------------------------------------
            child[grow = 45, concept color = green!50!yellow!70!black]{
                node[concept](func){Ecosystem Function}
                    [counterclockwise from = -20]
                    child{node[concept](massflu) {Mass Fluxes}}
                    child{node[concept](biom) {Biomass}}
                    child{node[concept](prod){Production}}
                    child{node[concept](comp) {Competition}
                        child{}}
                    }
        %----------------------------------------------------------
            child[grow = 0, concept color = blue!60!white]{
                node[concept](rough) at (0.5,0){Turbolence}
                    child[grow = 20]{node[concept](lh){Latent Heat}}
                    child[grow = -20]{node[concept](sh){Sensible Heat}}};
        %----------------------------------------------------------

%%%%%%%%%%%% ATMOSPHERE
  \path[mindmap,concept color=blue!80!white!60!green, text=white]
    node[concept](atmos) at (12,4){Atmospheric Exchanges};

%%%%%%%%%%%% ENERGY
  \path[mindmap,concept color=red!50!black, text=white]
    node[concept](energy) at (12,-4){Surface Energy};

%%%%%%%%%%%%% MAKING SECONDARY CONNECTIONS 
  \newcommand{\conngreentoorange}{to[circle connection bar switch color=from (green!50!yellow!70!black) to (orange)]}
  \newcommand{\connredtoorange}{to[circle connection bar switch color=from (red!50!black) to (orange)]}
  \newcommand{\connredtoblu}{to[circle connection bar switch color=from (red!50!black) to (blue!60!white)]}
  \newcommand{\connazuretoblu}{to[circle connection bar switch color=from (blue!80!white!60!green) to (blue!60!white)]}
  \newcommand{\connazuretogreen}{to[circle connection bar switch color=from (blue!80!white!60!green) to (green!50!yellow!70!black)]}
  \newcommand{\connazuretored}{to[circle connection bar switch color=from (blue!80!white!60!green) to (red!50!black)]}
  \newcommand{\connblutogreen}{to[circle connection bar switch color=from (blue!60!white) to (green!50!yellow!70!black)]}
  \begin{pgfonlayer}{background}
    %\draw [circle connection bar ]
      \path (func)  \conngreentoorange (light);
      \path (energy)\connredtoorange (alb);      
      \path (energy)\connredtoorange (lw);
      \path (energy)\connredtoblu (sh);
      \path (energy)\connredtoblu (lh);
      \path (atmos) \connazuretoblu (lh);
      \path (atmos) \connazuretoblu (sh);
      \path (atmos) \connazuretored (energy);
      \path (atmos) \connazuretogreen (massflu);
      \path (lh) \connblutogreen (massflu);
  \end{pgfonlayer}
\end{tikzpicture}}
\end{figure}

\end{document}

This is my result:

enter image description here

closed as too localized by Matthew Leingang, Mensch, Speravir, Werner, Thorsten Mar 14 '13 at 6:04

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to TeX.sx! I get correct output from your example. Can you add information about the TeX distribution you're using? – egreg Mar 13 '13 at 22:43
  • 1
    With MacTeX, there is no problem. Have you try different PDF viewers ? – projetmbc Mar 13 '13 at 22:47
  • I am using TeXShop for mac. I just installed it yesterday. I will try other options to see if something changes – user27342 Mar 13 '13 at 23:42
  • After testing your code (re-edited) it works for me too. There is something on my document breaking the graph. What a pain, the document has 300 pages :/ – user27342 Mar 13 '13 at 23:49
  • No problem here either on Mountain Lion, pgf version 2.10, using Preview. – jub0bs Mar 14 '13 at 0:00

Browse other questions tagged or ask your own question.