9

I read many things about XeLaTeX and I wanted to give it a try, but I wasn't able to figure out how to make use of Type 1 fonts, in my case especially the font Lucida, which I bought from pcTeX (which don't offer OpenType, unlike TUG). In normal LaTeX it was as easy as

\usepackage{lucimatx}

I tried a solution as proposed here: Xelatex / Fontspec how to load fonts directly from diskfile (Postscript Type 1 fonts)

\setmainfont[Path=/usr/local/texlive/2012/texmf-dist/fonts/type1/bh/lucida/]{lbr.pfb}

but this produces strange errors like

** WARNING ** Obsolete four arguments of "endchar" will be used for Type 1 "seac" operator.
** ERROR ** This font using the "seac" command for accented characters...

Conclusion: Is there an easy way to use Type 1 fonts with XeLaTeX?


MWE for the solution using \setmainfont

\documentclass[11pt]{scrartcl}
\usepackage{polyglossia}
\usepackage{xunicode}
\usepackage{xltxtra}
\setmainlanguage{german}
\setmainfont[Path=/usr/local/texlive/2012/texmf-dist/fonts/type1/bh/lucida/]{lbr.pfb}
\begin{document}

Im folgendem Abschnitt wollen die Eigenschaften des Drehimpuls untersuchen,
was uns auf die \emph{Drehimpulsalgebra} führen wird. Als eine fundamentale
Eigenschaft, aus denen wir die meisten Resultate in diesem Abschnitt erzielen
werden ist, dass der Drehimpuls (angular momentum) der infinitesimale Erzeuger
der Rotation ist.

\end{document}
5
  • 1
    Not an answer per se to your problem, but faced with a similar desire to use the Lucida fonts with XeLaTeX I sprung for the Lucida OpenType fonts available from TUG (tug.org/store/lucida/opentype.html). Well worth the $90 for an individual license.
    – Paul M.
    Commented Mar 14, 2013 at 19:48
  • 1
    @Paul M.: Of course this is an option, but as I already stated in the question, I do own a license for Lucida Type 1 and as I'm a poor student I can't afford it twice. Thank you anyway! Commented Mar 14, 2013 at 19:53
  • 2
    I guess that begs the question -- why use XeLaTeX in the first place, if the font you want to use works perfectly fine in PDFLaTeX? Is there a particular feature of XeLaTeX that you'd like to exploit?
    – Paul M.
    Commented Mar 14, 2013 at 20:03
  • 2
    The main advantage I want to make use of is, that I can type UTF-8 right away without the need to find a package which yields the desired symbol. Commented Mar 14, 2013 at 20:07
  • 2
    With \usepackage[utf8]{inputenc} you should not get any problem with texts containing ÄäÖöÜüß and pdflatex. Of course, you must encode the files in utf-8.
    – Speravir
    Commented Mar 15, 2013 at 1:43

1 Answer 1

3

It seems that the umlaut in "führen" is causing the problem. When I change your MWE as follows, it gives me a font substitution warning but otherwise compiles just fine:

\documentclass[11pt]{scrartcl}
\usepackage{polyglossia}
\usepackage{xunicode}
\usepackage{xltxtra}
\setmainlanguage{german}
\setmainfont[Path=/usr/local/texlive/2012/texmf-dist/fonts/type1/bh/lucida/]{lbr.pfb}

\begin{document}
Im folgendem Abschnitt wollen die Eigenschaften des Drehimpuls untersuchen,
was uns auf die \emph{Drehimpulsalgebra} fuhren (\verb=<-- umlaut removed=) wird. Als eine fundamentale
Eigenschaft, aus denen wir die meisten Resultate in diesem Abschnitt erzielen
werden ist, dass der Drehimpuls (angular momentum) der infinitesimale Erzeuger
der Rotation ist.
\end{document}

I don't know if this is a XeLaTeX bug or a problem with the Lucida Type 1 fonts.

For more info on this issue, see the following thread from the XeTeX mailing list:

http://www.mail-archive.com/[email protected]/msg04433.html

1
  • Thank you for fixing that one, but unfortunately all my major documents are typeset in German, so omitting umlauts is not bearable. I think the error is due to Lucida as XeLaTeX advertises full UTF-8 compatibility. Commented Mar 14, 2013 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .