15

I am using WinEdt with MikTeX 2.9 in a Windows 7 environment.

I am having issues being able to get text in parentheses working correctly with a citation, specifically that when the document prints to PDF I get extraneous parentheses that should be removed by the natbib command I am using.

I wish to have the following text:

(cited in Axelrod 1997)

But I keep getting:

(cited in Axelrod (1997))

I have tried using two methods to remove the extraneous pair of brackets. First I tried:

\citep[cited in]{Axelrod2}

and then I tried:

\citetext{cited in \citealp{Axelrod2}}

but both give me the same result: two sets of parentheses.

Could someone please advise me where I am going wrong? I have the natbib reference document, and I was copying from the examples in there.

I am using a document template created for my university and I have the following packages and options being loaded:

\usepackage[english]{babel}
\usepackage{amsmath,amsthm}
\usepackage{amsfonts}
\usepackage[a4paper,layout=a4paper,
        bindingoffset=4cm,left=0cm,right=2cm,
        head=2.5cm, bmargin=2cm]{geometry}
\usepackage{microtype}
\usepackage{verbatim}
\usepackage{graphicx}
\usepackage{url}
\usepackage[round]{natbib} 
\usepackage{listings}
\usepackage{booktabs} 
\usepackage{multirow}
\RequirePackage[l2tabu, orthodox]{nag}
\usepackage{cleveref}
3
  • Hi there, I have changed the loading order to put cleveref last and used your \citealt suggestion. This removed the extra brackets, and inserted a comma between the author and the year. I seem to be experiencing some weird effects with the natbib package. I can live with the comma. If you put your suggestion as an answer, I can vote it as such. :)
    – Michelle
    Commented Mar 14, 2013 at 21:29
  • In this case \citep[cited in][]{Axelrod2} seems like a good way to go.
    – moewe
    Commented Apr 26, 2020 at 6:05
  • Anyway, \citetext{cited in \citealp{Axelrod2}} should only produce one pair of parentheses. I could not reproduce the output you describe in the question with the code shown so far. It should work. Something else must be going on.
    – moewe
    Commented Apr 26, 2020 at 6:07

1 Answer 1

25

The natbib package provides the following four basic citation commands: \citet, \citep, \citealt, and \citealp.

When using an author-year citation style, the output of these commands looks like this (assuming that (i) the key axel97 points to an entry written by Axelrod in 1997 and (ii) one uses the plainnat or similar bibliography style):

enter image description here

Since you're looking to typeset the citation without parentheses and commas, you should use the command \citealt.

If you keep getting different results, try loading the natbib package either earlier or later in the preamble (while taking care to load the cleveref package last).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .