3

I freshly installed 2.9

I tried to compile a XeLatex document, which works fine on my work computer.

I got the following error:

expl3.sty missing.

It tries to install l3kernel

starting package maintenance...
installation directory: "C:\Program Files (x86)\MiKTeX 2.9"
package repository: http://distrib-coffee.ipsl.jussieu.fr/pub/mirrors/ctan/system/win32/miktex/tm/packages/
lightweight database digest: b641b9d295dbd4c2d5caa951cd9d95e3
going to download 6240193 bytes
going to install 44 file(s) (1 package(s))
downloading http://distrib-coffee.ipsl.jussieu.fr/pub/mirrors/ctan/systems/win32/miktex/tm/packages/l3kernel.tar.lzma...
6177780 bytes, 227.61 KB/Sec
visiting repository http://distrib-coffee.ipsl.jussieu.fr/pub/mirrors/ctan/systems/win32/miktex/tm/packages/...
repository type: remote package repository
loading lightweight database...
downloading http://distrib-coffee.ipsl.jussieu.fr/pub/mirrors/ctan/systems/win32/miktex/tm/packages/miktex-zzdb1-2.9.tar.lzma...
130729 bytes, 141.07 KB/Sec
lightweight database digest: b641b9d295dbd4c2d5caa951cd9d95e3
xelatex.EXE: The operation could not be completed because the following file failed verification:
xelatex.EXE: 
xelatex.EXE: C:\Users\y\AppData\Local\Temp\mikAB2F.tmp
======================================================================


! LaTeX Error: File `expl3.sty' not found.

I get the same error when I try to install the package via the package manager

The operation could not be completed because the following file failed verification:
C:\Users\y\AppData\Local\Temp\mikD002.tmp
6
  • 1
    This might be a MiKTeX bug; while I didn’t try reinstalling, I got the same error error message about files with a similar name in the equivalent directories on two different computers when I tried to update.
    – doncherry
    Mar 15, 2013 at 14:30
  • 6
    There seems to be currently quite a lot of problems with the package installation in miktex. Some of the checksums are faulty (and some of the mirrors are down). Mar 15, 2013 at 14:49
  • 2
    I have the same problem and tried few different mirrors with no luck.
    – Wildcat
    Mar 15, 2013 at 19:59
  • So I just wait a few days and then I try to reinstall everything...
    – dziadgba
    Mar 15, 2013 at 23:27
  • 2
    @dziadgba: Things seems to be back to normal. I just could run the update which failed two days ago. Mar 16, 2013 at 17:10

0

Browse other questions tagged .