38

--UPDATE--

I've installed biblatex via the command "sudo apt-get install biblatex". However I now get a partially generated pdf like this:enter image description here instead of the desired output of: enter image description here

--UPDATE--

I've found TexMaker very easy and helpful with the pdf file it generated whenever you pressed the "Quick Build" button.

Sadly when I started writing slightly more complicated scripts (my current Tex document) that required biblatex for references whenever I clicked on the "Quick Build" button I get the following error:

! LaTeX Error: File `biblatex.sty' not found.

Instead to build my pdf I need to type the following in the command line:

pdflatex test.tex
biber test
pdflatex test.tex

A similar question was asked here but I really don't want to use a script each time I need to compile my Tex document.

My echo $PATH is "/usr/local/texlive/2012/bin/x86_64-linux:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games" and here is the current configuration of TexMaker TexMaker commands TexMaker Quick Build

17
  • What's the output of tlmgr install biblatex (or with sudo if not enough permissions)?
    – T. Verron
    Mar 16, 2013 at 19:18
  • Where and how was biblatex installed, and what permissions does it have?
    – jon
    Mar 16, 2013 at 21:01
  • 1
    @JohnCrawford kpsewhich biblatex.sty at terminal will confirm its path and presence. Mar 16, 2013 at 21:45
  • 2
    @JohnCrawford Looking at the options you have, you'll need to choose either a pre-built script such as latexmk, a more flexible system such as arara or 'roll your own' if you want to have Biber run automatically by Texmaker. Perhaps pop over to chat as this might need quite a bit of discussion.
    – Joseph Wright
    Mar 16, 2013 at 22:13

3 Answers 3

120

This was clearly not the problem for OP, but since I came here via Googling, this might help future suffers of this message.

On my system (Linux Mint 17.2), my texlive installation didn't include biber and I had to run:

sudo apt-get install texlive-bibtex-extra biber

after which all ran fine.

3
  • 1
    Your solution is extremely helpful!!, Thanks a lot!!
    – Charlotte
    Dec 19, 2020 at 6:51
  • 4
    can I marry you? This answer has helped me a LOT! thank you!
    – eli44
    Jun 23, 2021 at 11:52
  • @eli44; haha, really nice!!
    – Charlotte
    Feb 20, 2022 at 14:07
9

So the solution was rather simple. Click on Options->Configure TexMaker. From there click on the "Tex Build" button. The go to the field "User" and enter the following: pdflatex %.tex | biber % | pdflatex %.tex | evince %.pdf This will then generate your pdf document from your Tex file and show the output to you

Here is a screen shot of the change needed.

enter image description here

1
  • If you only want to use biber occasionally, or want to reserve your QuickBuild shortcut for something else, you can also define it as a user command by going to User->User Commands->Edit User Commands and assigning the same sequence to one of the five user commands. It will then be available via the respective shortcut or in the left of the two dropdown boxes in the main toolbar.
    – ThomasH
    Aug 23, 2014 at 23:41
1

I had the same problem and could solve it (Debian 10, TexMaker) by installing texlive-bibtex-extra and texlive-lang-english:

sudo apt install texlive-bibtex-extra
sudo apt install texlive-lang-english

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .