1

I'm having some trouble trying to use kpfonts. [I'm using a Linux system, with TexLive2010.] I copied the kpfonts files to my local texmf directory as per the instructions, and then ran

 updmap --enable Map=kpfonts.map

That seemed to work properly. But when I try to use kpfonts in a document I get the following error:

ERROR: LaTeX Error: This NFSS system isn't set up properly.

--- TeX said ---

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
...                                              

l.5 \begin{document}

--- HELP ---
From the .log file...

For encoding scheme OML the defaults jkp/m/it do not form a valid font shape

Minimal document I'm working on:

\documentclass{article}
\usepackage[veryoldstyle]{kpfonts}
\begin{document}
This is a test. Duct, dust, and so forth.
\end{document}

Web searches haven't turned up any solutions; has anyone got any idea about what might be wrong?

  • 3
    Just to check: you downloaded texlive 2010 from the tug website and installed it that way? If it's a version of texlive packaged in a flavour of linux like ubuntu, it won't be 2010. Why didn't you install kpfonts through tlmgr? – Seamus Feb 5 '11 at 16:42
  • For some reason, when I first went to tlmgr, I couldn't find kpfonts. But I checked again now, and it's there.... So it looks like I just made extra work for myself before. Thanks! – emacsomancer Feb 5 '11 at 16:47
  • 2
    If it's on CTAN, it should be possible to install it through tlmgr. I'd try hard to avoid installing packages manually unless you really need to. – Seamus Feb 5 '11 at 17:09
  • 1
    Seamus - me too. And I was surprised when I couldn't find it at first. – emacsomancer Feb 5 '11 at 17:21
2

try this: sudo updmap-sys --enable Map=kpfonts.map if you installed TeX Live as root.

  • 3
    LaTeX Error: This NFSS system isn't set up properly. is a latex error. It indicates a bug in the package (in this case one that has been corrected already). It has nothing to do with map-files. – Ulrike Fischer Feb 5 '11 at 16:58
  • I actually had tried sudo updmap-sys --enable Map=kpfonts.map after I couldn't get it to work the first time (though I hadn't installed TeX Live as root), and got the same error. Installing for tlmgr as Seamus suggested worked [again, I don't know why I couldn't find it in tlmgr the first time I looked.]. Thanks all. – emacsomancer Feb 5 '11 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.