3

Situation: I've got Myriad Pro included in xetex via:

\setmainfont[Mapping=tex-text]{Myriad Pro}

But when I use

\textbf{this is a test}

and see the result in Acrobat, I can see that I've gotten "MyriadPro-BoldCond" rather than only "MyriadPro-Bold". I need a suggestions on how to change the behaviour so that I get "bold", not bold condensed.

  • (EDIT: thought it was a LuaTeX question first time.) What does your .log file say? A minimal document yields for me: Font family 'MyriadPro(0)' created for font 'Myriad Pro' with options.... – jon Mar 24 '13 at 21:48
  • Out of curiosity: Do you happen to run MacTeX? The reason I ask is that I've encountered similar problems (actually, running LuaLaTeX rather than XeLaTeX) when trying to load a font such as Garamond Premier Pro via a \setmainfont directive; the italics font that is loaded if no explicit ItalicFont = ... is provided turns out to be Garamond Premier Pro Semibold Italic rather than Garamond Premier Pro Italic... I have no idea if MacTeX or MacOSX is the culprit, or how long this has been going on. – Mico Mar 25 '13 at 1:57
  • @Mico, no, I am running MikTeX with Windows underneath, but as you say, I have the suspicion that the underlying system has to do something with it; – Gabriel Mar 25 '13 at 8:51
  • @jon, . fontspec info: "defining-font" . . Font family 'MyriadPro(0)' created for font 'Myriad Pro' with options . [Mapping=tex-text]. . . This font family consists of the following shapes: . . * 'normal' with NFSS spec.: . <->"Myriad Pro/ICU:script=latn;language=DFLT;mapping=tex-text;" . . * 'bold' with NFSS spec.: . <->"Myriad Pro/B/ICU:script=latn;language=DFLT;mapping=tex-text;" . . * 'italic' with NFSS spec.: . <->"Myriad Pro/I/ICU:script=latn;language=DFLT;mapping=tex-text;" . . * 'bold italic' with NFSS spec.: . <->"Myriad Pro/BI/ICU:script=latn;language=DFLT;mapping=tex-text;" – Gabriel Mar 25 '13 at 8:52
  • \AtBeginShipoutBox=\box41 LaTeX Font Info: External font cmex10' loaded for size (Font) <7> on input line 29. LaTeX Font Info: External font cmex10' loaded for size (Font) <5> on input line 29. – Gabriel Mar 25 '13 at 8:55
7

The following setup should ensure the use of the desired bold fontface:

\setmainfont[Mapping=tex-text, % better, set "Ligatures = TeX",
             BoldFont={Myriad Pro Bold}] % you may also want to consider "Myriad Pro Semibold"
       {Myriad Pro}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.