3

I try to implement this interesting solution for latexdiff and multiple files. There are other questions regarding missing perl scripts but I cannot relate them or their solutions to my problem (i.e. perl script not found)(perhaps because I am a beginner). However using...

  • Win7 (64-bit)
  • GitHub (Sourcetree, Git version 1.8.0msysgit.0)
  • MikTex 2.9
  • ActivePerl version 5.16.2.1602
  • cygwin

I receive the following error:

Error

I am a beginner but already checked that Algorithm-diff is installed:

C:\progs\perl\site\lib\Algorithm

algorithm-diff (perl) is installed

Can someone help? I cannot find the path /usr/lib/perl5.... Latexdiff is installed in C:\Program Files\MiKTeX 2.9\scripts\latexdiff. Perl is installed in C:\progs\perlbut the folder lib\perl5is not there.

Update:

Tried to implement this solution for How to change @INC to find Perl modules in non-standard locations by adding C:\progs\perl\site\lib to the new Environment (User) Variables PERL5LIB and PERLLIB. It did work.

  • By any chance are they related ? Problem executing script for latexdiff. – texenthusiast Mar 27 '13 at 3:31
  • I also had this issue and found that by using a theportable version of perl from strawberryperl.com/releases.html, placing this in C:\tmp\perl running C:\tmp\perl\portableshell.bat and then running latexdiff from there worked fine – pluke Dec 30 '19 at 11:02
  • 1
    for those who end up here, you need to make sure you are adding the latexdiff to the right version of Perl. If you are on Windows use where perl and on Linux/macOS use which perl. If you have multiple versions of perl then you might face some issues. – Foad Feb 10 at 10:23
1

Questions answered, see update above: "adding C:\progs\perl\site\lib to the new Environment (User) Variables PERL5LIB and PERLLIB."

| improve this answer | |
  • 1
    Put your answer in the answer, not the question. – Tvde1 Feb 6 '19 at 10:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.