5

I'm using xetex 3.1415926-2.2-0.9995.2 (TeX Live 2009/Debian). I'm trying to run xelatex inside chroot jail.

I've copied following binaries and directories:

pdftex
bibtex
xdvipdfmx
xelatex

/usr/share/tex-common/  
/usr/share/texlive-base 
/usr/share/texlive-bin  
/usr/share/texmf        
/usr/share/texmf-texlive
/usr/share/fonts        
/var/lib/tex-common     
/var/lib/texmf          
/etc/texmf              
/etc/fonts

Also I tried to copy another tex binaries (tex latex pdflatex xetex) but it's not helped.

When I try to compile minimal xelatex sample

\documentclass[a4paper]{article}
\begin{document}
hello world
\end{document}

everything is fine in standard environment, but when I try to compile it inside chroot jail I have (pdf file not produced)

Error 32512 (driver return code) generating output;
file simple.pdf may not be valid.

If I compile it with -no-pdf option everything is fine, xdv file produced.

When I run xdvipdfmx -vvv simple.xdv I have no warnings or errors and even get pdf, but process finished with 139 exit code.

What am I doing wrong?

  • I guess that xdvipdfmx needs gs – egreg Mar 26 '13 at 18:39
  • @egreg: not true; I haven't had GhostScript installed and XeTeX has worked fine. Grigory: I guess one option could be to download texlive and point the install script into the to-be-chrooted directory. – morbusg Mar 26 '13 at 18:44
  • @morbusg Nice to know. One should at least know what the exit code 139 means. – egreg Mar 26 '13 at 18:49
  • @egreg I've added gs to jail but it's not helped: the same behaviour. @morbusg installing texlive not an option by requirements, but thanks for idea! – Gregory Kalabin Mar 26 '13 at 19:08
  • Have you ldd'ed all the binaries to make sure all the libraries are included? – morbusg Mar 27 '13 at 6:17
4

I solved the problem. Here is the list of missing dependencies:

  • /bin/sh
  • /usr/bin/basename - used by xdvipdfmx
  • /usr/bin/gs - sometimes needed for images processing
  • /tmp - prevents segfaults

Also useful dependencies:

  • /proc and /etc/ld.so.cache - prevent complaining of xetex about "can't open file for reading"
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.