4

Under Emacs 24.3 and Auctex, the sub/superscript fontification is occurring outside math modes. This appears in either Beamer or normal LaTeX docs.

Per this question, I've included the following lines in my .emacs.d:

    ;; disable annoying fontification in latex
    (setq font-latex-fontify-script nil)

However, this only appears to fix the behavior for a subset of letters for the subscript, and not at all for the superscript. Something like _p is fine. But _v gets set as the subscript. Both ^v and ^p get set as superscripts.

Has anyone else run into this problem? This is AucTeX 11.86 and Emacs 24.3, running on ubuntu 12.04.

4
  • Math-mode fontification appearing in normal text isn't normal, as far as I can remember (I don't have emacs 24 or auctex 11.86 here to test, unfortunately). I would search for "hidden" things tricking auctex into thinking it's in math mode. The best candidate is a $ in a comment. If it happens even at the very beginning of the document, this comment won't help you though.
    – T. Verron
    Mar 28, 2013 at 22:01
  • Update: it appears this is caused by bad behavior in latex-pretty-symbols.el, which was loaded as part of the Emacs starter kit. Mar 28, 2013 at 22:16
  • So what was the resolution for this? What can I do to disable annoying formatting - driving me insane right now
    – ilya
    May 31, 2015 at 23:49
  • @ilya are you sure (setq font-latex-fontify-script nil) does not work you? I tried it on Emacs 24.4 with the latest AucTeX, which works perfectly.
    – xuhdev
    Jan 21, 2016 at 20:19

2 Answers 2

2

Try using the following:

(fset 'tex-font-lock-suscript 'ignore)
1

See some of the answers here. In your .emacs.d, place the line

(setq tex-fontify-script nil)

The font-latex-fontify-script property that you reference applies only if you are using the font-latex scheme (which comes packaged with things like AUCTeX). For a generic setup, use tex-fontify-script.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .