1

I want to add a section to my contents pages so that it includes the cover sheet on the contents page (personally I don't like it but it has to be done). It is easy if I have

\section{Cover Sheet}

at the start of my cover sheet but I don't want that on the cover sheet? I assume it will be something to do with the

\addtocontents{toc}

command, though I am not sure how. Any help?

\documentclass[a4paper,fleqn]{article}
\begin{document}
%%%%INSERT COVER PAGE DETAILS%%%%%
\newpage
\section{Abstract}
%%%%INSERT ABSTRACT%%%%%
\newpage
\tableofcontents
\newpage
\section{Project}
\end{document}

As an additional, if any given answer could include the way to include the contents page on the table of contents, that would save me the trouble of researching that (I've just realised it would be helpful when typing out my question). Thanks.

3

For the first issue, you could use \addcontentsline (possibly with some provision to generate the appropriate anchor using \phnatomsection if hyperref is going to be loaded). For the second issue, you could use the tocbibind package (you can pass options to the package to not include the bibliography and the index):

\documentclass[a4paper,fleqn]{article}
\usepackage{tocbibind}
\begin{document}
\csname phantomsection\endcsname
\addcontentsline{toc}{section}{Cover Page}
THE COVER PAGE DETAILS
\newpage
\section{Abstract}
%%%%INSERT ABSTRACT%%%%%
\newpage
\tableofcontents
\newpage
\section{Project}
\end{document}

enter image description here

  • I'm currently reinstalling miktex so that I can install the package, but one thing has struck me and that is that the Cover Page and Abstract have the same page number in your example? – DannyBland Mar 29 '13 at 1:52
  • 1
    @DannyBland that's just because there was no real text added to the cover page in my example; once you add the actual cover page content, the numbering will be updated accordingly. I did a mock-up in my updated answer. – Gonzalo Medina Mar 29 '13 at 1:54
  • I assumed it was something small like that, and indeed it has worked. Thanks! – DannyBland Mar 29 '13 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.