I am trying to generate a bibliography with no luck until now. I get an empty one. Here is my code.

\documentclass[12pt,twoside, openright, a4paper]{report}










my biblio.bib is

    author = "test",
    title = "test",
    year = 2010,

and in TeXworks I use the option "XeLaTeX+MakeIndex+BibTeX". I read somewhere that I had to include the plain.bst file. Did it but didn't work. I tried everything. Any ideas?

  • Welcome to TeX.sx! did you run bibtex separately after you ran latex? that's necessary -- latex does not read or process .bib files; it requires a .bbl file "digested" by bibtex. (so then, after bibtex is run, you must run latex again.) Mar 29, 2013 at 14:13
  • 2
    Do you actually cite any entry in your document? If not, the bibliography will be empty.
    – lockstep
    Mar 29, 2013 at 14:26
  • @barbarabeeton No I didn't run this and as I see there is no .bbl file in my working directory. I tried to compile my tex file with only bibtex option and this generated a .bbl file with this content \begin{thebibliography}{} \end{thebibliography}
    – theoddone
    Mar 29, 2013 at 14:32
  • 1
    @theoddone Your given example is not a minimal working example (MWE) in the sense we need it here.
    – Speravir
    Mar 29, 2013 at 21:01
  • @barbarabeeton The options "PdfLaTeX+MakeIndex+BibTeX" and "XeLaTeX+MakeIndex+BibTeX" call in MiKTeX-TeXworks the binary texify, what is a MiKTeX speciality similar to latexmk. This calls actually BibTeX if necessary.
    – Speravir
    Mar 30, 2013 at 4:11

4 Answers 4


Too long for a comment: Let's try us another way. Can you please compile the following MWE on your system? It works for me with pdflatex -- bibtex -- pdflatex -- pdflatex.

%File mb-bibtex.tex, then \jobname = mb-bibtex
\RequirePackage{filecontents}        % loading package filecontents
% writing file \jobname.bib, for example mb-bibtex.bib.
  author    = {Goossens, Michel and Mittelbach, Frank and Samarin, Alexander},
  title     = {The LaTeX Companion},
  edition   = {1},
  publisher = {Addison-Wesley},
  location  = {Reading, Mass.},
  year       = {1994}
  title     = {The Restaurant at the End of the Universe},
  author    = {Douglas Adams},
  series    = {The Hitchhiker's Guide to the Galaxy},
  publisher = {Pan Macmillan},
  year      = {1980}


\usepackage[numbers]{natbib}         % bibliography style
\usepackage[colorlinks]{hyperref}    % better urls in bibliography

Test of bibliography: 
The \LaTeX{} companion~\cite{companion}, the funny book of Adams~\cite{adams}.

\bibliographystyle{plainnat}  % needs package natbib
\bibliography{\jobname}       % uses \jobname.bib, according to \jobname.tex

To be sure (that there is no error in your config of your editor) please use the terminal/console.

  • 1
    It works for me also with TeXworks/MiKTeX and the option “pdfLaTeX+MakeIndex+BibTeX”.
    – Speravir
    Mar 29, 2013 at 21:00

I had the exact same problem, and I was finally able to diagnose and solve my problem. I am posting so others may find this potential problem as I have not seen this as a solution to this problem.

I am working on a Windows 7 machine (ugh--it's my office's requirement). After an hour+ of trouble shooting, I found my problem was the file type of my .bib file. I had exported from Endnote to bibtex (or so I thought). Endnote made a .txt file. I manually changed this to a .bib file.

However, the file was actually just retitled myLib.bib.txt. Yuck.

When I opened my myLib.bib.txt in JabRef and did a "SaveAs" choosing .BIB fileType, everything finally worked. I did the normal:

  1. pdfLatex myFile.tex
  2. bibtex myFile.aux
  3. pdfLatex myFile.tex
  4. pdfLatex myFile.tex

Again, now everything worked. It was a filetype error that was leading to an empty .bbl file. When I say empty, previously my .bbl file had only the \begin and \end lines, with no actual content.


Maybe it is because you haven't explicitly cited "tess".

I mean, there could be two things here:

1) You haven't cited "tess" (by using the comand \cite{tess}), and therefore, you don't get it on your bibliography. This is often used for "references" instead of "bibliography", where "references" means citations and specific referals to a certain document and "bibliography" are ALL the papers, books, articles and stuff you went through your investigation.

If this is the case, don't worry, you'll get your references printed when you actually \cite them.

2) You want to get ALL your bibliography entries printed. If this is the case, please add \nocite{*} to your code and that's it: you'll get all your 'biblio' entries printed whether you cited them or not along the text.

Extra thing: Don't forget to run the whole thing a couple of times to allow the creation and update of the required auxiliary files.

  • I tried adding \nocite{*} and didn't work. Still empty.
    – theoddone
    Mar 29, 2013 at 14:30
  • Well, then we can try a couple of things: first, please make sure ---in your project properties--- you have checked "Uses BibTex", and second please try changing your entry from "conference" to "inproceedings" Mar 29, 2013 at 14:37
  • Where is the Uses BibTex option. inproceedings has the same result.
    – theoddone
    Mar 29, 2013 at 14:43
  • Mario, I guess you mix up TeXnicCenter with TeXworks.
    – Speravir
    Mar 29, 2013 at 20:48
  • 1
    @theoddone, as stated above, a Minimum Workign Example could really clarify this situation. I'm very intrigued what may be causing this. What I do feel is that since the same behavior exists whether \nocite{*} is used or not, your problem has something to do with your settings and not with your code per se. Mar 30, 2013 at 3:16

Well, I used texstudio. I had the exact same problem. 1. run Pdflatex 2. run Bibtex 3. run Pdflatex

Kindly refer the associtated figuressteps

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .