4

This question already has an answer here:

I'm drawing the following cylinder which represents a water flowing and cooling down

\documentclass[a4paper,10pt]{article}
\usepackage{pstricks}
\usepackage{auto-pst-pdf}
\usepackage{pst-solides3d}
\usepackage{xcolor}
\usepackage{epstopdf}
\usepackage[english]{babel} %change language if necessary
\usepackage[english,verbose]{layout}%change language if necessary

\begin{document}

\begin{pspicture}(-3,-4)(3,4) 
\psset{viewpoint=50 50 20 rtp2xyz,Decran=50,lightsrc=viewpoint 
} 
 \psset{color1=cyan,color2=red} 
 \psSolid[h=8,r=0.5, object=cylindre, ngrid=50 15, RotZ=30,
hue =1 0 0 0 0 1,linewidth=0.01pt ](0,0,-2.5)  \end{pspicture}

\end{document}

I would like the black lines to disappear, or atleast partially merge with the image. Is there anyway to perform this ?

marked as duplicate by Paul Gessler, Werner, Jesse, Mike Renfro, Svend Tveskæg Jan 13 '15 at 2:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you try to use 0pt for the line width? – Sigur Mar 30 '13 at 0:03
  • 1
    Yes, it makes white lines which are not really pretty. I have found a way though. Set linewidth = 0pt and plot a second cylinder on top of the first with a slightly different ngrid. – Mathusalem Mar 30 '13 at 8:09
  • @Mathusalem: linewidth=0pt is not the correct way. See my answer – user2478 Aug 3 '14 at 13:45
1
+50

Use option grid:

\documentclass{article}
\usepackage{auto-pst-pdf}
\usepackage{pst-solides3d}
\begin{document}

\begin{pspicture}(-3,-4)(3,4) 
\psset{viewpoint=50 50 20 rtp2xyz,Decran=50,lightsrc=viewpoint,
  color1=cyan,color2=red} 
\psSolid[h=8,r=0.5, object=cylindre, ngrid=50 15, RotZ=30,
  hue =1 0 0 0 0 1,grid=false](0,0,-2.5)  
\end{pspicture}
\end{document}

enter image description here

  • It seems that this does not work when the option opacity is used for transparency. – Hugo Raguet Aug 26 '17 at 16:32
  • action=draw* should help – user2478 Aug 26 '17 at 18:20
  • actually mixing action=draw* with grid=false makes the strangest behavior: only hidden grid lines are shown (but dashed). – Hugo Raguet Aug 26 '17 at 22:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.