Hi I've scoured the internet for a solution for my spellchecker problem but with no luck. The problem is that when I write misspelled Hebrew text nothing happens I did follow the guide at their website which explains tow to setup Hebrew in whole and the spellchecker but it just doesn't work.

First I'd get the following error

    spell checker has no dictionaries

But then this error disappeared and now when I press F7 it just claims to have reached the end of the document in spite of the document being full of gibberish. I've checked and the relevant files are present (he_IL.aff , he_IL.dic). I've all so added my LyX directory structure to pastebin as well as my languages file content.

I've tried:

  • Changing the ducument encoding
  • Tried to write "Hebrew" and "hebrew" in the spellchecker menu.
  • Reinstall the whole thing (voodoo solution do work occasionally).

This is a source of a file containing just 2 words which are both gibberish:

    % Preview source code

    %% LyX created this file.  For more info, see http://www.lyx.org/.
    %% Do not edit unless you really know what you are doing.

    %%%%%%%%%%%%%%%%%%%%%%%%%%%%%% Textclass specific LaTeX commands.

    %%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.


    טעטעעטעטע שדגשדג

If you need any other information I'd be glad to provide it.

Edit 1: I'm using LyX with Hunspell.

  • @e-birk I'm using LyX with Hunspell. – SadStudent Mar 30 '13 at 18:24
  • Have you set something in "Tools > Preferences... > Language Settings > Spellchecker > Alternative language"? I will get this error if the field is not empty. After clearing this field, a restart of LyX seems necessary. Then your words are marked as unknown by the spell checker. (Probably you have already read wiki.lyx.org/Devel/Hunspell) – e-birk Mar 31 '13 at 17:39

Well I've solved the mystery, the real cause is rather peculiar and somewhat embarrassing.

The first time it did not work I've tried fixing the paths in the "Preferences -> Paths" menu and after reading that LyX had their own dictionary repository I've decided to update mine, what could go wrong?

So today when I've decided to tinker with the spellchecker some more I've noticed that Hebrew's dictionaty is a bit smaller than the others, so I've decided to open the file.

What I've discovered was quite funny actually somehow I've (or FireFox) downloaded the source of the html page on LyX's Trac containing the actual file but not the file itself (it did automatically get the right name and .dic and .aff extensions ) but they were html files.

After downloading them again (correctly this time) the spellchecker sprang to life and now it works. So the lesson is that it's important to verify that the files we place in the "dicts" folder are indeed dictionaries and not some html impostors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.