4

At first I was using \linespread{2} but my research told me to use the package setspace. I did this and everything is fine however in align* environments, my equations get double spaced also which makes it visually unappealing. I tried two options

\usepackage{setspace}
\doublespacing
%\displayskipstretch %to avoid stretching math formula
\abovedisplayshortskip=0pt
\belowdisplayshortskip=0pt
\abovedisplayskip=0pt
\belowdisplayskip=0pt

which doesn't do anything.

I then tried writing \singlespace right before my align environment. This works however there's a very big gap between paragraph and align - see picture. (Note that this happens in the above case also). I would preferably like a single, 1.2, or 1.3 spacing in between equations and doublespace in "text mode"

picture

edit: after viewing the pdf again, I am okay with the double space (again I would prefer single). However the whitespace between the paragraph and the align is very visually unappealing

5
  • 4
    Load the package with the nodisplayskipstretch option: \usepackage[nodisplayskipstretch]{setspace}. Apr 1, 2013 at 5:52
  • Idea: Put \newcommand*\AlignDots[2]{\setbox0\hbox{${}#1{}$}\hbox to\wd0{\hfill$#2$\hfill\strut}} in the preamble and use \AlignDots to get vertically dots aligned correctly (instead of the horizontal ones). Apr 1, 2013 at 11:20
  • @GonzaloMedina I tried that and it works but there is still a fair bit of gap (although less now)
    – masfenix
    Apr 1, 2013 at 16:37
  • 1
    @masfenix Then try adding this in the preamble (after loading setspace): \doublespacing \setdisplayskipstretch{0.3}. Adjust the value 0.3 according to your needs. Apr 1, 2013 at 18:20
  • I think the problem is with the "cases" left bracket i have. Anyways, is there a way to also force singlespace in math mode?
    – masfenix
    Apr 1, 2013 at 19:12

1 Answer 1

2

For anyone in future who comes looking, and as this didn't quite fit in a comment, the spacing between the paragraph and the align can be reduced by using a \vspace with negative spacing after the \singlespacing. Note that there must be a blank line between the preceding paragraph and the \singlespacing otherwise it will make that paragraph single spaced.

By using

text

\singlespacing
\vspace{-0.8cm}
\begin{align}
    y_1 &= ax_1 + b\\
    y_2 &= ax_2 + b
\end{align}

\doublespacing
text

I was able to get reasonable results.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .