I haven't been doing much LaTeX'ing and just installed TeX live 2012 last night. Now one of my documentation projects stops compiling due to the following snippet:

\chapter{List of publications}

It seems maxnames and minnames are now removed for printbibliography. How to fix this without changing the global settings? Thanks.

The snippet is sort of an innovative use of biblatex to list my publications. It used to work with biblatex 1.4c. It should display full author list for that particular chapter.

EDIT: sadly I am struggling with English to clarify my question. It involves a complex use of biblatex and not about using maxnames or minnames or printbibliography, which are clearly explained in the manual.

  • If the entries you want to use full name lists for are guessable from the author list or from being in a seperate file, it is possible to do this with a biber sourcemap, adding the correct options dynamically to the entries. To show you how, we'd need some sort of MWE thoughg.
    – PLK
    Apr 3, 2013 at 18:55

2 Answers 2


This is essentially impossible and may only have worked with biblatex <2.0 because that didn't have the ability to have multiple \printbibliography with different sorting. maxnames/minnames affects many things which biber does like label generation, sorting, name hashes etc. and so hacking this with \setcounter will almost certainly not do what you want as this only affects the biblatex side of things. Maybe if you can give a MWE of what you are trying to do exactly and we can see if it can be done with the available options. I'm open to enhancements if there is a use case not dealt with.

  • The requests of users are infinite so you can open a new issue ;-) Apr 1, 2013 at 9:41
  • You are probably right. I have little idea how things have changed in the last 3 years. The snippet included is literally a chapter of my documentation project. I think people can get the idea what it tries to accomplish.
    – Leo Liu
    Apr 1, 2013 at 9:55
  • 2
    If you are trying to make sure your name appears in all of your own publications where you may be listed beyond the global maxnames limit, you can set maxnames/minnames per-entry using the options field in the .bib file. Simply set it to something suitably large for papers you were author on so that you appear.
    – PLK
    Apr 1, 2013 at 12:42

maxnames and minnames are legal options for the document preamble. The options are described in the manual in section General which is introduced with:

The following options may be used in the optional argument to \usepackage as well as in the configuration file and the document preamble.

Allowed options of \printbibliography are listet in section 3.6.2 The Bibliography. There you can't find the option maxnames nor minnames.

Fazit: maxnames and minnames exist but only in the preamble.

Hack: you can set \setcounter{maxnames}{15} and \setcounter{minnames}{15}.

Here an example (without refsection):






  • Yes I gathered these info as well from the biblatex 2.5 manual. maxnames and minnames used to work on v1.4c at least. What I am asking is how to translate the snippet to 2.5. Thanks.
    – Leo Liu
    Apr 1, 2013 at 9:18
  • 1
    I tried adding \setcounter{maxnames}{15} and \setcounter{minnames}{15} in between the refsection env. No it doesn't work.
    – Leo Liu
    Apr 1, 2013 at 9:34
  • @LeoLiu: I added an example Apr 1, 2013 at 9:39
  • I updated the purpose of the snippet. I know how maxnames should be used then and now. But what I am trying to is to use biblatex to print a list of publications from Publications.bib. So in my project I actually have two .bib files: one for the citations and one for this particular chapter.
    – Leo Liu
    Apr 1, 2013 at 10:02
  • @LeoLiu: I ams using the newest version of biblatex. So I can't test yours. Apr 1, 2013 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.