29

I'm using TeXstudio 2.5.2 together with Jabref 2.9.2 and BibLaTeX. Everything in my document works fine except that when I enter \cite no pop-up with all the bibliography entries shows up. The weird part is that it didn't work at first, then after a hint of a colleague it did and now it doesn't work anymore. Now I know, that this isn't the biggest problem in the world (especially when you're using Jabref, since there's a button to push a citation to your TeX file) but sometimes it would be nice to have the popup.

Below I have a minimal "working" example (obviously if one adapts the directories) - what I'm doing is, is calling the \printbibbliography command in an external .tex file called Verzeichnisse (which is then called by the the input command) - this is due to said tip of my colleague which acutally worked at first.

Does anymone have an idea to make this thing work (again)?

\documentclass[a4paper, parskip, 11pt, chapterprefix, numbers=noenddot]{scrbook}

\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage[backend=biber,style=alphabetic,sorting=anyt,maxalphanames=1,maxnames=99,
maxcitenames=2,natbib=true]{biblatex}

\renewcommand*{\labelalphaothers}{}
\addbibresource{Bibliography.bib}

\input{Kapitel/Verzeichnisse}

\begin{document}
\end{document}
2
  • 1
    From my work with TeXstudio I assume the file with the bibliography entries must be opened in TeXstudio. Commented Apr 2, 2013 at 21:55
  • Thanks for your answer - that's what I acuatlly did at first and it didn't work. That's also why I tried this detour via the external .tex-file, which actually worked at first. I just tried to open the bibliography file in the main file, but the popup still doesn't show up
    – Bobby
    Commented Apr 3, 2013 at 8:29

9 Answers 9

17

So, I've got the solution (i.e. someone more intelligent than me told me) - the problem was, that there was a hard-line break in \usepackage[...]{biblatex}. After fixing it the cite popup was showing up again.

3
  • 5
    Thanks for this answer, it fixed the problem for me as well. Just to clarify a little: if you use linebreaks if the \usepackage[...]{biblatex} line, this seems to freak out texstudio and makes the autocompletion not work. I just got rid of those linebreaks and it now works great. Commented Oct 14, 2014 at 2:50
  • 1
    I hope someone filed the bug...
    – Himura
    Commented Mar 29, 2017 at 8:55
  • Hm, I also had linebreaks in my usepackage statement but removing them didn't solve the problem. I still don't get autocompletion or popups in TeXstudio when using \cite{.... Instead, it still says "citation not found" inside the editor - but builds the PDF without problems. Did I miss something? Commented Jul 28, 2021 at 8:34
15

I faced the same problem with TexStudio 2.8.4 and I figured out that when I used \addbibresource, TexStudio did not add the myBib.bib to the document structure. The solution is first close the file and open TexStudio options>configure TexStudio> Completion and check biblatex.cwl. Then open your .tex file and use \addbibresource, you will notice that the .bib file is added to your document structure. The autocomplete should appear when you use \cite{}

2
  • How do I check the document structure? Checking biblatex.cwl in options did not resolve the problem for me. Commented Jul 28, 2021 at 9:45
  • Great answer!! Thank you very much! Commented Jan 8, 2023 at 18:24
7

I had the same problem, but with a different cause and solution.

In my case, it broke when I changed the Default Bibliography Tool to biber in Preferences -> Build.

I think that this probably removed the bibliography cache, but didn't regenerate it.

The solution was as follows (assuming you use biblatex):

  1. Change the default bibliography tool to the tool to biber.
  2. Comment out the line \usepackage{biblatex}.
  3. Compile the document. (There will be lots of errors, but that's OK.)
  4. Uncomment the line \usepackage{biblatex}.
  5. Compile the document again.

Autocomplete should now be working again.

4

So I know this is an old thread, but I wanted to post my own solution to my identical problem since nothing else worked.

I was using a hierarchical structure with one master document, several \include{} documents, and in some of those I even had \input{} documents:

master.tex

-included1.tex

-included2.tex

--input1.tex

--input2.tex

Now, I discovered that the citation list popped up just fine in the include{} documents, but not in the input{} documents, which lead me to believe that texstudio could not figure out the master document of the input{} documents, but it could do this just fine for the include{} documents.

This turned out to be correct: By adding the "magic comment" % !TEX root = ../../master.tex everything worked fine and autocomplete came back up. Of course, do edit the relative path so it fits your situation.

EDIT: It appears after some testing, that the file in which the bibliography is defined must have been opened in a separate tab, before the autocomplete works even though the "magic comment" is defined. The file can be opened and closed immediately - it doesn't have to stay open. Only then can the citation autocomplete open.

3
  • I assume that you added the magic comment on top of every included and inputted document?
    – Lukas
    Commented Sep 16, 2018 at 14:25
  • In the end, I believe that what actually ended up working is simply opening the bibliography file in TexStudio, and then just closing it again. Having been opened seems to add all references to the cache of TS, or something like that.
    – Kaspar H
    Commented Jul 29, 2019 at 12:08
  • For me it works if I put the \bibliography{...} in the file I'm editing instead of including it. Commented Oct 11, 2019 at 12:28
2

I had same problem. I don't know the reason but a strange thing worked.

I have all my preamble in a separate file which I insert using \input{settings}, this file contains package declarations for bibliography and bib resources. As long as the settings.tex file is not open on texstudio, I don't get drop down list of bib items. So simply opening this file in the same editor worked. Probably, this works for someone else and someone can explain this strange behaviour.

1
  • thank you. This solved the issue. very weird behaviour for the editor.
    – seteropere
    Commented Oct 12, 2016 at 7:40
1

I had a similar issue. Found that changing the \addbibresource to an absolute path worked. For example, this did not always work:

\addbibresource{~/Documents/bibliography.bib}

but this now always works:

\addbibresource{/Users/user/Documents/bibliography.bib}

Using TeXstudio 2.12.2, Jabref 3.8.2, on macOS Sierra.

I hope this can be useful to someone else.

1

I had the same problem in a document assembled from a number of subfiles and could fix it with the following steps:

  • Unchecking biblatex.cwl in Options > Configure Texstudio > Completion.
  • Closing the dialog
  • Opening the same dialog again and checking biblatex.cwl.
0

I had the same problem and the auto-complete used to work. I tried all the suggestions on this page but to no avail.

Instead, I found (from another forum post) that if you press CRTL+Space with the cursor inside the \cite{} command, the auto-complete list appears again.

Hopefully this will also work for other people.

1
  • can you link to that post?
    – naphaneal
    Commented Nov 2, 2016 at 11:00
0

When the \cite{} drop-down has worked for you in the past, but is suddenly not working in a new project

I was in the above stated situation. In the past for TeX projects that had a .bib file, I was able to get a drop-down menu with text-matching whenever I started typing within the \cite{} command. However, when I recently made a new TeX project, the drop-down menu stopped appearing.

Strangely, when I opened the old project again to check if the feature was still working there, the feature started working in the new project as well.

I don't know if this was a "fix" or just a coincidence, but this might help others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .