4

Don't know what I did (if I did anything) but seems multilingual libraries don't work for me anymore... I have some german and english references in an english document and so I want that english references are all output in small letters - for german titles, however, I want to keep the original spelling, including all capitals. Here's a minimal example:

\documentclass[10pt,oneside,a4paper]{scrartcl}

\usepackage[utf8]{inputenc}
\usepackage[usenames]{color} %used for font color
\usepackage{graphics}
\usepackage[british,german]{babel}
\usepackage{csquotes}
\setquotestyle{british}
\usepackage{mathdots}
\usepackage{amssymb} %maths
\usepackage{amsmath} %maths
\usepackage{authblk}
\setcounter{secnumdepth}{-1}

\clubpenalty=10000
\widowpenalty=10000
\displaywidowpenalty=10000


% ********************************BIBLATEX**************************
\usepackage[language=british,isbn=false,authordate,doi=false,babel=other]{biblatex-chicago}

\defbibheading{quell}{\section{Primary Ressources}}
\defbibheading{lit}{\section{References}}
% ******************************************************************

references would be, for example:

@book{aunger_darwinizing_2001,
title = {Darwinizing Culture: The Status of Memetics as a Science},
isbn = {0192632442},
language = {english},
hyphenation = {english},
pagetotal = {256},
publisher = {Oxford University Press},
editor = {Aunger, Robert},
date = {2001-01-04},
}

@book{rautenberg_einfuhrung_2008,
location = {Wiesbaden},
title = {Einführung in die mathematische Logik: ein Lehrbuch},
isbn = {9783834805782 3834805785},
shorttitle = {Einführung in die mathematische Logik},
hyphenation = {german},
publisher = {Vieweg + Teubner},
author = {Rautenberg, Wolfgang},
date = {2008},
}

but what happens is that all are

  • The language=british option setting prints the bibliography under one language module - british. To obtain a multilingual bibliography, remove this setting and leave babel=other as-is. If the main document language is English, you should load babel with british last: \usepackage[german,british]{babel}. – Audrey Apr 5 '13 at 14:55
  • I tried this but it still gives me: Aunger, Robert, ed. 2001. Darwinizing Culture: The Status of Memetics as a Science. Oxford University Press. Although it should be: Aunger, Robert, ed. 2001. Darwinizing culture: The status of memetics as a science. Oxford University Press. The problem are not the German entries as one would expect... how is this even possible? It seems the bibliography is printed receiving completely all format features from the bib file... – obsrvng_obsrvrs Apr 5 '13 at 16:49
  • I found in the biblatex manual that By default, converting to sentence case is enabled for the following language identifiers: american, british, canadian, english, australian, newzealand as well as the aliases USenglish and UKenglish. Use \DeclareCaseLangs to extend or change this list. but that's simply not true since even when I leave out the babel option and do not use any other options than ecessary it gives me no sentence cased titles... I would be very grateful for help, really I have no idea... – obsrvng_obsrvrs Apr 5 '13 at 17:41
  • 3
    Refer to the biblatex-chicago manual on title casing. The 0.9.9b release notes state that you should use the authordate-trad style to obtain sentence-style capitalization in titles. – Audrey Apr 5 '13 at 17:58
  • Thank you so much!!! you saved my day! Just wasn't carful enough... Cheers! – obsrvng_obsrvrs Apr 5 '13 at 18:02
2

The Chicago Manual of Style no longer imposes sentence-style capitalization on titles. In response to this change the biblatex-chicago author moved sentence case title formatting from the default authordate style to a new style call authordate-trad. So to obtain an English bibliography with sentence-cased titles load babel and biblatex with the option settings:

\usepackage[german,british]{babel}
\usepackage[authordate-trad,babel=hyphen]{biblatex-chicago}

For a multilingual bibliography incorporating both English and German strings, change the setting babel=hyphen to babel=other. Note that you might need to protect some words in titles from down-casing. For example:

title = {Darwinizing Culture: {The} Status of Memetics as a Science},

Alternatively you can use the subtitle field:

title = {Darwinizing Culture},
subtitle = {The Status of Memetics as a Science},

Also note that sentence case is applied only under the language modules specified in \DeclareCaseLangs. By default:

\DeclareCaseLangs{%
  american,british,canadian,english,australian,newzealand,
  USenglish,UKenglish}

To include german in this list, add the following to your preamble:

\DeclareCaseLangs*{german}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.