I'm using a custom class file.

My main file looks like this:

\documentclass[12pt,a4paper]{thesis}
\begin{document}
\frontmatter
    \pagenumbering{alph}

    \pagenumbering{roman}
    \clearpage

    \cleardoublepage
    \tableofcontents
    \clearpage
    \listoffigures
    \clearpage
    \listoftables

 \mainmatter
       \part{test}
      \input{test}
\end{document}

If I put this in my test.tex it does work:

\chapter{test}
\label{chapter:test}
test 

When it becomes more text (lets say 40x the word "test") I get the error stated in my question title.

To test it I brought my class file down to this:

\ProvidesClass{thesis}
\NeedsTeXFormat{LaTeX2e}

% Based on the memoir class
\DeclareOption*{\PassOptionsToClass{\CurrentOption}{memoir}}
\ProcessOptions
\LoadClass{memoir}

I'm totally confused what is causing my error now.

This is the complete error:

! pdfTeX error (font expansion): auto expansion is only possible with scalable 
fonts.
\AtBegShi@Output ...ipout \box \AtBeginShipoutBox 
                                                  \fi \fi 
  • 1
    I have this error with package frutiger since Tex Live 2016, with 2015 everything works fine. – Matthias Pospiech Jun 19 '16 at 15:27
  • 1
    I'm not quite sure what the problem was but I was getting that same error trying to run the Annalen der Physik class over a newish installation of MikTeX. Related to the advice here, running initexmf --mkmaps made the problem go away. – E.P. Feb 1 '17 at 0:36
  • 2
    I think I figured out two things: 1. Thanks to @Krebto and his answer I realised that this error can be removed by running the updmap.exe in the miktex installation directory. 2. I think if you are asked to install a new package via a software like texmaker or texworks or if you are compiling a .tex file and during this compilation, if a new package is installed, then the miktex itself is not being updated for some reason. If you then run updmap.exe immediately after, this error message vanishes. – ramanunni.pm Dec 23 '17 at 22:16
up vote 58 down vote accepted

You have to load a scalable font like lmodern:

\usepackage[T1]{fontenc}
\usepackage{lmodern}

or install the cm-super fonts.

  • 2
    But wait, i wanna use Minion Pro. Does this mean i cant use it or? – Elmer Feb 9 '11 at 21:04
  • 1
    As far as I know there is no configuration for MinionPro – Herbert Feb 9 '11 at 21:22
  • 2
    no, for microtype. There must be a configuration file which defines what to do with the characters. – Herbert Feb 9 '11 at 21:37
  • 4
    @Herbert, @Joseph: Microtype works fine with every (scalable) font. If no specific configuration file exists it falls back to the default configuration. The error message above means that the document is using a bitmap font. A new configuration file will not solve the problem. – Ulrike Fischer Feb 11 '11 at 14:20
  • 6
    I don't fully understand why this answer is accepted. This sounds like the solution is to not solve the problem, right? Or am I doing something wrong, and this answer really provides a solution how to use MinionPro with microtype? 5 years ago, I successfully wrote my diploma thesis with MinionPro + microtype following these instructions, so in general it is possible, but using the more recent FontPro approach gives me the same problem as the OP. – bluenote10 Mar 14 '14 at 16:16

UPDATE: Added cm-super. Please comment if that does not help in your case.

First of all (as pointed out by @Herbert), you have to load a scalable font such as lmodern or mathptmx:

\usepackage[T1]{fontenc}
\usepackage{lmodern}

This, however, did not solve the issue on my freshly installed MiKTeX system. I had to install the cm-super package and to update MiKTeX completely.

I had to do the following steps:

  1. Start "MiKTeX Package Manager (Admin)"
  2. Install the cm-super package.
  3. I would recommend to update all packages to the latest version as described at https://tex.stackexchange.com/a/108490/9075.
  4. Start "MiKTeX Settings (Admin)"
  5. Press "Refresh FNDB"
  6. Press "Update Formats"
  7. Press "OK" (to close the app)
  8. Recompile. Everything should work.

MiKTeX settings

See also https://docs.miktex.org/manual/configuring.html#fndbupdate

The installation hint of the cm-super package is taken from https://tex.stackexchange.com/a/310169/9075 and was also stated by @Herbert

MiKTeX does not automatically install cm-super when using microtype. This was discussed on the mailinglist on 2016-11, but no action was taken.

Check in the log-file in which package/file microtype is loaded and comment the call. Then compile your document (now without the microtype package) with pdflatex. Then check at the end of the log-file the list of fonts and identify the bitmap font(s) (with ending .pk) causing the problem.

  • 1
    Check in the log-file in which package/file microtype is loaded how can I notice/identify that? – Kristof Tak Nov 2 '14 at 0:23

Configuration files for fonts can be found in tex/latex/microtype/ subdirectory of your TeX installation.

But wait, i have no configuration file for PSCyr font; however i can use font expansion in a way like this (stretch and shrink are way too large, for the sake of demonstration):

% in preamble:
\SetExpansion[stretch = 70, shrink = 70,] { encoding = {T2A} } { }
\DeclareMicrotypeSet{t2atext}{encoding=T2A}
\UseMicrotypeSet{t2atext}

An i have result like this:

enter image description here

It's clear, i have font expansion working here.

The point is that configuration file contains commands for character protrusion and font expansion --- like this one --- nothing special or magic.

So, you can write your own command, you can collect them in your own configuration file for your favorite font face.

Read manuals, specify your values (encoding!) and enjoy.

  • Im reading into it now. So ehm, i should use the microtype package first. And when that doesent work ur way of making my own configuration file with commands. Is there some explanation somwhere (on a noob level) on how to do what you just explained? – Elmer Feb 11 '11 at 18:35
  • microtype's manual is great! Well, i set stretchability and shrinkability to 70/1000th of em --- for T2A-encoded font. And asked microtype to use these rules. Like that. Just try!-) You will like it. – brownian Feb 11 '11 at 19:15
  • I got it all working now. Just some text looks weird, i think cuz of Minion Pro not being able to handle it. For instance: when i type griffie it looks like this in my pdf:ifïnAe. Is this something that could be fixed using microtype? I checked the microtype manual but thats abracadabra to me. – Elmer Feb 13 '11 at 18:26
  • Well, i've never got things like that. You can, however, try to disable ligatures (the manual, section 8), i would try this \DisableLigatures[ri]{encoding = T1} (and, possibly, experiment a bit more). – brownian Feb 14 '11 at 14:22
  • @Elmer could explain how did you make it work? – Kristof Tak Nov 2 '14 at 0:22

To solve the problem navigate to C:\Program Files\MiKTeX 2.9\miktex\bin\x64 and run updmap.exe. The program may seem as it hangs for a while, but its probably because it tries to update the whole font tree. This solved the problem for me. After re-compiling everything should work fine.

  • 1
    I personally think, this answer is more pertinent than the other answers. Because the other answers basically ask you to default back to lmodern, which is not useful at all, if you are trying to write a thesis/important document which necessitates the use of a particular font. And not only did this work, it works like a charm for almost all fonts in the Latex Font Catalogue which previously gave this issue.Can you explain why this is the case though? Thanks again.. – ramanunni.pm Dec 23 '17 at 22:05
  • 1
    Because I don't understand the logic as to why this doesn't happen by default when you run the package manager/update settings in miktex. – ramanunni.pm Dec 23 '17 at 22:07
  • 1
    This actually solves the problem and isnt a work around – Julian_W Mar 5 at 9:54
  • 1
    I can confirm that this does not require any change in the document. It just works. – miho Jun 23 at 11:12

Not really an answer, but just a post-mortem on a tricky variation of this error to watch out for; this is a bit too long for a comment.

I had loaded Utopia as the main document font (using \usepackage[utopia]{mathdesign}) as well as \usepackage[stretch=15,shrink=15]{microtype}. Everything went swimmingly, until I typeset a single character in sans-serif (\textsf{Y}). Then I got the auto expansion is only possible ... error.

The funny part was that the error was flagged on a paragraph that was downstream of the \textsf{Y} macro, but which itself contained only regular text in Utopia. When I commented out the upstream \textsf{Y}, the error disappeared. Likewise, when I loaded the lmodern or the berasans package together with [utopia]{mathdesign}, the error was gone.

If I understand the situation correctly, Utopia comes without matching sans-serif fonts, so when pdflatex encountered the \textsf{Y}, it fell back on the default CM fonts, which are not scalable; and from that point on in the document, microtype gave up on scaling.

Morale: make sure to load scalable fonts for all font shapes that you might use anywhere in the document, not just for your main document font.

I had the same error after installing latex from scratch using texlive-full. What solved it for me was to simply do

updmap

which updates the fonts (https://www.tug.org/texlive/doc/updmap.html). I found this solution here: https://github.com/xdanaux/moderncv/issues/34

The following command works for me. Pls try this, it helps me to fix this headache!!!

initexmf --mkmaps 

works!!!

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.