1

I've been using aquamacs 2.4 on my osx 10.7.5. After it crashed with my font change operation, the preview menu bar disappeared and doen't appear again after rerunning the program. Although I reinstalled the aquamacs package, the problem was not fixed. Could anybody help me on this problem?

  • Is AUCTeX still loaded on your emacs? (I believe both are pre-packaged with Aquamacs nowadays, but I can't be sure since I'm a GNU Guy. AUCTeX and preview are closely intertwined.) Also, could you elaborate on this 'font change operation'? Which fonts were you changing? – Sean Allred Apr 5 '13 at 22:39
  • Try renaming the "Aquamacs Emacs" folder in ~/Library/Preferences/ so as to start in a fresh state. – egreg Apr 5 '13 at 23:22
1

The problem was the .emacs file in my home directory. I put below contents, which I copy and pasted, to enable spell checking function. Once I remove the contents, the preview function turn on. But I'm still not aware of why following made the problem. Thank you for all in this thread.

(setq ispell-program-name "aspell") ; could be ispell as well, depending on your preferences

(setq ispell-dictionary "english") ; this can obviously be set to any language your spell-checking program supports

(add-hook 'LaTeX-mode-hook 'flyspell-mode)

(add-hook 'LaTeX-mode-hook 'flyspell-buffer)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.