I've been using LyX with vector images in *.eps format for the longest time. Now I've moved to a new machine (a mac), tried to get the same work environment back, and ran into this problem:

Creating pdf's from the original LyX document, all my nice vector images are being converted to low resolution rasterized images.

It seems like this is somehow related to XeTeX, since when I don't use XeTeX, everything looks just fine. Am I missing some package? Is there some LyX option that's misconfigured?

Edit: Just noticed something important: in the folder containing the *.eps images, low resolution pdf images are being created. Looks like the *.eps is being converted to a rasterized pdf. Very strange.

  • You could convert your EPS files to PDF. On a Mac this as easy as opening it in Preview and saving the generated PDF. Or there are command-line utilities to do it. – Matthew Leingang Apr 8 '13 at 15:42
  • @MatthewLeingang - I could, but I would prefer to solve the original problem. Converting all eps files to pdf can be time consuming for very large documents, and eps is easier to edit later. The weird thing is - it worked fine on linux, so is this a mac issue? – nbubis Apr 8 '13 at 15:48
  • 1
    To really solve the problem we would need a minimal example that illustrates your problem. – Matthew Leingang Apr 8 '13 at 15:55
  • 1
    Concerning your edit: As a short-term solution, you could give the extension in the \includegraphics statement, since the default in XeTeX is to prefer pdf. You could also change the order of the selection of graphics filename extensions, without changing every \includegraphics. Nevertheless, it would be best to find the creator of the pdfs to not run into this problem again. The pdf metadata could be of help with finding the creator of the pdfs. – Chris Apr 8 '13 at 16:27
  • 1
    While XeTeX can include EPS files, I've found that in some cases there are small problems. The best is to convert the EPS files into PDF with a program such as epstopdf – egreg Apr 8 '13 at 16:34

For further reference, epstopdf is named epspdf on macports, and LyX had to be configured to mirror that change:

Lyx -> Preferences -> File Handling -> Converters

In EPS -> PDF change "Converter to

epspdf $$i $$o"

I'm still not sure what mechanism was forming the pdf beforehand, but at least there's a solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.