2

I'm writing a paper for an IEEE conference and am checking the PDF with PDFExpress. One of the errors that I'm getting is that the PDF version of my paper is under 5: (actually "version 5" in an Adobe Acrobat Reader version - editor)

PDF Version too low

I opened the file in Adobe Acrobat Reader and the file properties tell me that the PDF is version 4. (that's the Adobe Acrobat version - editor)

In LyX, I opened Document > Settings… and unchecked Use Hyperref Support under PDF Properties. I think these will take care of errors (1), (2) and (4) from the error report. However, I don't see a way to specify a PDF version.

enter image description here

I found this other solution, which made LyX complain about a missing \begin{document}.

So now I'm completely lost. How may I specify what PDF version to export the document in?

( Editors Note: The current version of the pdf open file format is 1.7 [2/7/2015]. Adobe Acrobat Reader is frequently, but not the only program, used to freely open pdf files. Createspace supports submittal pdf file in version 1.4 and below. They do not say they support pdf file format version 1.5 or above, which is this editors problem )

Technical specs:

  • LyX version 2.0.5.1
  • Mac OS X 10.7.5 (Lion)
  • MacTeX version: enter image description here
  • What version of MacTeX do you have? You find it in the System Preferences pane called "TeX Distribution". – egreg Apr 11 '13 at 23:53
  • Following the instructions on this post, I believe I have TeXLive-2011 v2.0 (build 150) – inspectorG4dget Apr 12 '13 at 0:01
  • On a related note: are you sure that the IEEE conference submission system or the conference organizers care about the fact that your PDF is compatible with older Acrobat versions? Using a lower PDF version is actually a plus for the file, not something bad. – DCTLib Apr 12 '13 at 1:02
  • @Ruedi: the submission system doesn't let me get past without passing these tests. So, I kinda have to go with the higher version – inspectorG4dget Apr 12 '13 at 1:15
  • This problem affected me directly. Just to clarify: Amazon Createspace says that it supports pdf submissions in pdf version 1.4 and below. Thousands of folks submit their publications in pdf format to Createspace. TeX and related software should be a significant contributor to the creation of those book submittals. And so Createspace and TeX users should be aware that LyX (2.0.6) uses pdfLatex to generate output in pdf version 1.5, which they don't say is supported. (I use Hyperef support in the pdf output) – user12711 Feb 7 '15 at 17:33
4

I think this problem can be solved using \pdfminorversion=4 before \begin{document}.

  • Doesn't work. It still makes PDF 4 documents – inspectorG4dget Apr 12 '13 at 1:58
  • It looks like the answer is correct now. Sorry for the typo... The \pdfminorversion should be 2, 3 or 4, which correspond to PDF version 3.0, 4.0 or 5.0 respectively. – user13907 Apr 12 '13 at 9:19
  • 1
    I added this to my LaTeX preamble (within LyX 2.0.6) and it created pdf file version 1.4, which is exactly what I needed for a CreateSpace book submittal pdf. (CreateSpace says in their guidelines they support pdf version 1.4 and below) I think there is a lot of confusion over the Adobe Acrobat Reader version, and the PDF file version. The two are not the same, one is an application's software version. The other is the PDF file format version, which is "open" and used by many more programs than just Adobe Acrobat Reader. – user12711 Feb 7 '15 at 19:11
1

The PDFExpress error message is about the Acrobat version, not the PDF version. This, of course, is misleading, but in fact means that PDFExpress wants PDF version 1.4, as 5 = 1 + 4.

For a long time Acrobat and (Acrobat) Reader had followed a simple and deterministic rule for their version number: The Acrobat version is the sum of the major and minor part of the highest PDF version it can process. So Acrobat 4 was for PDF 1.3, Acrobat 5 for PDF 1.4 and so on. Basically, the development of both went hand in hand and new features of the PDF format lead to a new release of the respective Acrobat tools.

However, since Acrobat version 9 this has stopped. Acrobat 9 still processes PDF 1.7 (as does Acrobat 8), but additionally supports some "Adobe extensions for PDF 1.7". Adobe has now decoupled their tool development from advances in the file format. From version 10 on (Acrobat X) this has also been reflected in the tool names, which now contain roman version numbers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.