1

This question already has an answer here:

When I compile a document with PdfLaTeX + View PDF quick build command option selected, Texmaker outputs these files in the same directory with the .tex file:

MyDoc.aux
MyDoc.log
MyDoc.pdf
MyDoc.synctex.gz

Among these files I only need the PDF file. The other compiler output files my be important for debugging or for some other purposes, but as a standard user I find them as nothing but garbage. How do I disable generation of these other three files?

marked as duplicate by Matthew Leingang, David Carlisle, Claudio Fiandrino, jub0bs, Mensch Apr 12 '13 at 10:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    You can't disable the generation. You can put the files in an extra directory or you can remove the files after compiling. – Marco Daniel Apr 12 '13 at 9:32
  • 2
    If you want your cross references to work (and tables of contents, index etc) those files are not garbage, they are where the information latex needs is stored. – David Carlisle Apr 12 '13 at 10:06
  • 1
    There is an option in Options -> Configure TeXmaker -> Commands. There you have a checkbox labeled: 'Use a "build" subdirectory for output files'. This will mean that the output PDF file will also go there. I don't know of any finer grained control as to where the different files should go. – Count Zero Apr 12 '13 at 11:28