I'm sorry if this exact question has already been asked, but the similar duplicates I've found didn't have the same phrasing. Therefore, I'm asking a new question...

I have WinEdt 7.0 on Windows 7 and I have Adobe Acrobat Pro 9.0. Whenever I open WinEdt and I compile a file, everything works like a charm. If I re-compile without closing Adobe, the compiling fails and I get an error:

Cannot Open DDE Link to:

"C:\Progam Files (x86)\Adobe\Acrobat 9.0\Acrobat\Acrobat.exe"

Service: AcroviewA11

Topic: Control


All of the problems I've found on the site have been related to changing acroview to acroviewA11, but I wasn't able to find these anywhere.

Can someone help me?

UPDATE: Since I can't post answers for another 6 hours, and I have a high probability of forgetting to return here and accept an answer, I'll post my exact actions here.

After going to Options Interface->Advanced Configuration->PDF Macros->Adobe Blues, and making the recommended changes from AcroviewA11 to Acroview according to this answer, I executed the macro by going to Macros->Execute Current Macro (or it can be done using Ctrl+Shift+F9). At this point, I checked and it worked! The error occurred because I run Adobe 9 and not Adobe 11; however, I'm not sure what the precise cause of it was.

  • 2
    The problem is probably that Reader locks the PDF for editing, so pdftex cannot change it. You could try Sumatra instead, this will auto-update the PDF if it changed. Apr 13 '13 at 18:38
  • 4
    Welcome to TeX.sx! the answer tex.stackexchange.com/a/73817/6621 may be useful
    – cmhughes
    Apr 13 '13 at 18:40
  • I don't think I will mind switching PDF viewers, but I'm rather ignorant as to how I should change the WinEdt settings for a default viewer. And, I'm not sure if it's relevant, but the problem is relatively new. I installed an update for Adobe, perhaps 3 days ago (who knows how old the update was, though), and that was what started the error messages.
    – anon271828
    Apr 13 '13 at 18:41
  • @cmhughes: I began reading with high hopes, but (at least according to the directions of that answer) my Adobe doesn't have a Protected Mode option. I went as far as to go to the help menu and perform a search query for "Protected Mode" with 0 results, and then I reduced the query to "Protected" with only 3 results, all of them unrelated.
    – anon271828
    Apr 13 '13 at 18:45
  • @TorbjørnT.: I hadn't tagged you earlier because I assumed you would revisit and check on the status of my question. At any rate, the Adobe Acrobat I have doesn't have an option for Protected Mode (see previous comments).
    – anon271828
    Apr 13 '13 at 19:24

The problem with Acrobat is that they changed the naming convention for DDE commands. For the version 11 you have to use AcroviewA11, for version 9 and before it was and has to be Acroview.

In question pdfopen-pdfclose user @user24452 showed how to do this. My answer showed how you can integrate also SumatraPDF into WinEdt.

As you wrote in your comment, after changing AcroviewA11 to Acroview use Ctrl+Shift+F9.

  • +1 for taking the time and helping me! I wish I could upvote twice, you've earned it :)
    – anon271828
    Apr 13 '13 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.