6

I'm not quite sure how to explain my problem. Please telle if you need more information. My document is very large and has a lot of settings. I'm using TeXnicCenter with the BibTex-Compiler 2.8. When I'm constructing the PDF (LaTeX->DviPS->PS2PDF), I'm getting this:

enter image description here

The BibTex-entry:

@incollection{Agrawal.2008,
 author = {Agrawal, Motilal and Konolige, Kurt and Blas, Morten Rufus},
 title = {{C}en{S}ur{E}: {C}enter {S}urround {E}xtremas for {R}ealtime {F}eature {D}etection and {M}atching},
 pages = {102--115},
 volume = {5305},
 publisher = {Springer},
 isbn = {978-3-540-88692-1},
 series = {Lecture Notes in Computer Science},
 editor = {Forsyth, David and Torr, Philip and Zisserman, Andrew},
 booktitle = {{C}omputer {V}ision -- {E}{C}{C}{V} 2008},
 year = {2008},
 address = {Berlin und Heidelberg},
 doi = {10.1007/978-3-540-88693-8\_8}
}

What's my problem? The DOI is displayed twice. And I only want the last notation (DOI.10.1007 ...). I've tried the doi-package but this causes a lot of trouble with my tex-files. Could you please help me? I will try to give further informations.

Minimal example:

\documentclass[a4paper,11pt]{scrreprt}
\usepackage[komastyle,automark]{scrpage2}
\usepackage[latin1]{inputenc}
\usepackage{graphicx}
\usepackage[a4paper,left=2.5cm,top=2.5cm,bottom=2.5cm,includeheadfoot,width=16cm]{geometry}
\bibliographystyle{alphadin2}
\usepackage[hyphens]{url}
\begin{document}

\chapter{TEST}
This is a test \cite{Agrawal.2008}.

\newpage
\addcontentsline{toc}{chapter}{Bib}
\bibliography{minimalbib} %Add the entry i this file
\end{document}
5
  • 1
    Please provide a minimal working example. Do you use biblatex? Your question is tagged with it but alphadin doesn't work with biblatex. Commented Apr 14, 2013 at 14:36
  • I'm not using biblatex. Sorry. I've added a minimal example. Commented Apr 14, 2013 at 15:11
  • alphadin2.bst isn't available at CTAN. Where does the file come from? Is it equal to alphadin.bst? Commented Apr 14, 2013 at 15:21
  • I found the the answer here: groups.google.com/forum/?hl=de&fromgroups=#!topic/… (German). However it's a bug of alphadin. You have to change a lot in alphadin.bst. Maybe biblatex is an option for you. Commented Apr 14, 2013 at 16:07
  • Please post your last comment as an answer so that I can accept it. It's no solution but it still helped. Thank you. Commented Apr 14, 2013 at 16:55

1 Answer 1

2

This behaviour is a bug of alphadin.bst. In a former question at comp.tex.tex DOI in alphadin (German) the method solving the issue is shown. However every entry type must be redefined.

In my opinion the package biblatex is an very good alternative.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .