9

I wanted to try the latest version of LuaTeX, so I downloaded the official precompiled binaries but these raw binaries are useless without a luatex.fmt. How can this file be created?

2 Answers 2

4

I'm assuming you have TeX Live installed, so will have the file 'luatex.ini'. You need that (i.e. copy to where you are going to generate your format file), as it specifies how to build the format. You should then be able to do

luatex -ini luatex.ini

to build the format file.

1
  • I lately had some problems with this solution and solved the issue by running fmtutil --all.
    – h0b0
    Commented Aug 17, 2010 at 9:34
0

I could generate the file in the right directory when executing

miktex --enable-installer formats build lualatex --engine luahbtex

This solved following error appearing in lualatex.log

2024-06-11 11:27:49,404+0200 INFO  lualatex - running on Windows 10.0.19045
2024-06-11 11:27:49,427+0200 INFO  lualatex - going to create file: lualatex.fmt
2024-06-11 11:27:49,427+0200 INFO  lualatex.core - start process: miktex --enable-installer formats build lualatex --engine luahbtex
2024-06-11 11:27:55,557+0200 ERROR lualatex - C:\MiKTeX\miktex\bin\x64\miktex.exe did not succeed; exitCode: 1
2024-06-11 11:27:55,558+0200 ERROR lualatex - output:
2024-06-11 11:27:55,558+0200 ERROR lualatex - Building format 'lualatex' with engine 'luahbtex'...

Sorry, but: Windows API error 2: The system cannot find the file specified.

2024-06-11 11:27:55,558+0200 FATAL lualatex.core - The memory dump file could not be found.
2024-06-11 11:27:55,558+0200 FATAL lualatex.core - Data: fileName="lualatex.fmt"
2024-06-11 11:27:55,558+0200 FATAL lualatex.core - Source: Programs\TeXAndFriends\luatex\miktex\miktex.cpp:74

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .