I want to put output files (.pdf) into a _out dir and auxiliary files such as .synctex.gz or .toc into a _aux subdir.

From the help it seems that the -d option is what allows one to do it, but if I try to use it I get a Segmentation fault at the end.

Am I using it wrong?

echo '\documentclass{article}
\end{document}' > a.tex
mkdir _aux _out

pdflatex -interaction=nonstopmode -synctex=1 -output-directory _aux "a.tex"
synctex view -i "5:1:a.tex" -o "_aux/a.pdf"
echo $?

gives the good output (page 2) and 0 exit status but:

mv _aux/a.pdf _out/
synctex view -i "5:1:a.tex" -o "_out/a.pdf" -d "../_aux/"
echo $?

gives the good output + a line:

Segmentation fault (core dumped)

and 139 exit status


synctex view -i "5:1:a.tex" -o "_out/a.pdf" -d "_aux/"
echo $?

gives just:

This is SyncTeX command line utility, version 1.2
Segmentation fault (core dumped)

and 139 exit status.

Version: 1.2 on Ubuntu 12.10 from texlive-full package.

  • Is this still a problem with the current distribution? – cfr Jul 4 '15 at 22:20
  • @cfr hasn't changed on Ubuntu 14.04. – Ciro Santilli 郝海东冠状病六四事件法轮功 Jul 5 '15 at 5:42
  • I have version 1.2 from TeX Live 2015. It works fine here. I can't reproduce the segmentation fault at all. So either it is because Ubuntu's TL is too old and something has been fixed since (not in synctex if it's the same version but maybe something else has changed) or it is something to do with Ubuntu's packaging. (How they are building the binaries, for example, or something necessary not getting included in the package.) – cfr Jul 5 '15 at 12:53
  • @cfr thanks for the info! The Ubuntu version is 2013.20140215-1 (I think that means 2013?). I will open a bug on the Ubuntu tracker and link from here. – Ciro Santilli 郝海东冠状病六四事件法轮功 Jul 5 '15 at 13:21
  • 1
    @cfr Tested on 15.04 and seems to work. Yay! – Ciro Santilli 郝海东冠状病六四事件法轮功 Jul 5 '15 at 14:40

On Ubuntu 14.04 the situation was the same, texlive version 2013.20140215-1

But then I've tried Ubuntu 15.04 in Vagrant, texlive package version 2014.20141024-2ubuntu1, and the following worked:

mv _aux/a.pdf _out/
synctex view -i "5:1:a.tex" -o "_out/a.pdf" -d "../_aux/"
echo $?

Seems fixed then.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.