7

Are there any specific options that I can enable or disable to improve compiling time ? I don't understand most of what is included in the settings so I can't decide on my own (new LaTeX user here).

For example, I recently learned that adding % !TEX TS-program = pdflatexmk at the start of the document automatically compiles twice to display the PDF. So maybe there are other quirks that I don't know of that can assist compiling speed instead ?.

These are the settings I have in TexShop Editor :

enter image description here

enter image description here

enter image description here

And the documents starts with :

% !TEX TS-program = pdflatexmk
\documentclass[12pt,a4paper]{report}
\usepackage[lmargin=3.81cm,tmargin=2.54cm,rmargin=2.54cm,bmargin=2.52cm]{geometry}
\linespread{1.5}
2
  • 1
    Off-topic: If you are simply trying to get 1.5X spacing, you are probably better off using the package setspace, though \linespread does have its place. (Can't help with the speed question. As far as I know, pdfTeX is appreciably faster than LuaTeX, and I don't really use XeTeX. You might want to search for questions related to dumping formats; but this is not a beginner topic.)
    – jon
    Apr 19, 2013 at 5:02
  • Related Speeding up LaTeX compilation and it's linked questions at right Apr 26, 2013 at 2:58

1 Answer 1

1

Your should check it on your own computer, but compiling from a command line may reduce the time noticeably.

4
  • How do I compile from the command line ?? I always press CMD+T (custom key mapping) to typeset.
    – Razor
    Apr 20, 2013 at 2:37
  • Roughly speaking: <name of the compiler> (e.g. latex, pdflatex) <name of your file> [options]. All in the present directory. Apr 20, 2013 at 2:41
  • @NLed And if you not familiar with the command line, here blog.teamtreehouse.com/… is one of tutorials for Mac OS. Apr 20, 2013 at 2:57
  • Since TeXShop just runs the same command, I see no reason to expect doing it manually to be any faster. I use TeXShop, and I've always found it to be plenty fast (this is on an iMac that's several years old), except for documents with lots of TikZ pictures. And the solution to that is to save the figures as images to include. Apr 26, 2013 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.