14

while compiling my tex file, I am getting lots of this error --

kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 0+540/600 --dpi 540 zplmr7v
mktexpk: don't know how to create bitmap font for zplmr7v.
dvips: Font zplmr7v not found,  using cmr10 instead.
</usr/share/texmf-texlive/fonts/pk/ljfour/public/cm/dpi600/cmr10.pk>
dvips: Checksum mismatch in font zplmr7v

so far I understood (after googling), I need to install a package called 'texlive-fonts-recommended' which is currently maintained as in the texlive version for Debian/Ubuntu. But I am using the main texlive2012 distribution from the CTAN (http://www.tug.org/texlive/acquire-netinstall.html). How do I do that? I am running a *nix system which is not a Debian derivative.

  • 2
    Did you actually install the TL12 from TUG? Because it does not place its files in the location you indicate. It seems that you have two LaTeX installations, and your document is not using the correct one. – daleif Apr 19 '13 at 8:25
  • 6
    Assuming your netinstall was succesfull, try issuing tlmgr info collection-fontsrecommended. If it says the collection is not installed, use tlmgr install collection-fontsrecommended. Depending on your installation directory, you may need root privileges to install new stuff. You may also need to do the same for collection-fontsextra. tlmgr also has a gui (if you like GUIs) that you may call with tlmgr --gui (it needs Perl/Tk installed) – Nico Boni Apr 19 '13 at 8:37
  • @daleif, yes there were some vestiges from the default texlive installations came with the OS (through Yast), I cleaned them up. But still getting the same error. – ramgorur Apr 19 '13 at 8:56
  • 4
    as a general rule, you should not mix CTAN packages with packages provided by your distro, you will break something eventually. Also, CTAN packages are usually more uptodate, so if you already have a working TeXLive from CTAN just stick with it. – Nico Boni Apr 19 '13 at 9:06
  • 1
    @ramgorur: There is a quite recent version of TL2012 for OpenSUSE in the repos... – Martin Schröder Apr 19 '13 at 17:14
17

from dcmst's answer --

user@host:~$ tlmgr install collection-fontsrecommended

Some systems might require to run tlmgr as root, so add sudo:

user@host:~$ sudo tlmgr install collection-fontsrecommended
4

sudo apt-get install texlive-full

This solves all the problems but it takes a long time to install :)

Good luck

  • 6
    Bit of a 'swatting a fly with a hammer'-solution. I much prefer the solution offered by dcmst in the comments, above. Run tlmgr install collection-fontsrecommended – Joost Sep 7 '13 at 12:41
  • I generally try to avoid `texlive-full', my connection is not that fast. – ramgorur Feb 15 '14 at 20:32
1

user@host:~$ sudo tlmgr install collection-fontsrecommended worked for me.

(where user@host:~$ is the root directory that you can go to by typing "cd /" in the terminal. In iMac that I am using, you can get the terminal screen in the utilities folder that itself is inside the application folder.)

I was stuck for the whole morning.

Thanks very much for saving me days! I would not have solved this problem by myself without the help of this post. Thanks again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.