This question already has an answer here:

(La)TeX newbie here. I'm writing my philosophy thesis in LyX. Loving it so far but trying to hack myself around the limitations of BibTex has been exhausting. Now – finally – I've gotten Biblatex to work in LyX - what a huge relieve! With babel it beautifully renders everything in the bibliography in to my language.

I just have two issues that I hope are easier to resolve now that I'm using Biblatex

I'm using the author-year style with this in my preamble:


1. I would like to separate year and cited page with colon instead of comma:


Wittgenstein 1961: §4.003, 36

Instead of this:

Wittgenstein 1961, §4.003, 36

2. I would like to have the name of an author with multiple works repeated:


Wittgenstein, Ludwig (1961). Tractatus Logico Philosophicus. Routledge & Kegan Paul. Wittgenstein, Ludwig (2010). Philosophical Investigations. en. John Wiley & Sons.

Instead of this:

Wittgenstein, Ludwig (1961). Tractatus Logico Philosophicus. Routledge & Kegan Paul.
– (2010). Philosophical Investigations. en. John Wiley & Sons.

Your help is much appreciated. I'm hoping that I soon will be able to spend more time on actually writing my thesis than familiarizing myself with TeX :)

marked as duplicate by lockstep, Gonzalo Medina, Claudio Fiandrino, Reinstate Monica - M. Schröder, Guido Apr 22 '13 at 14:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Use the dashed=false package option and add the following to your preamble: \renewcommand*{\postnotedelim}{\addcolon\space}. See also tex.stackexchange.com/questions/12806/… – lockstep Apr 22 '13 at 12:30
  • Please, note that you don't have to sign with your name since it automatically appears in the lower right corner of your post. – user13907 Apr 22 '13 at 12:47

Thanks a lot! My questions were answered in the comments thusly:

Ad. 1.


Also if you want to remove "p." after the colon add:


Ad. 2. Add dashed=false to \usepackage[...]{biblatex}

Not the answer you're looking for? Browse other questions tagged or ask your own question.