I have a tex file that compiles from the command line when I run pdflatex. However, when I run the same command from PHP/Apache, I get a fatal error. I also get a file called "missfonts.log" produced, which contains the following:

mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 ecsi0800

In my output log, these are the last two lines:

!pdfTeX error: pdflatex (file ecsi0800): Font ecsi0800 at 600 not found
==> Fatal error occurred, no output PDF file produced!

I don't know what ecsi0800 refers to - it's not in my tex file anywhere.

I've tried various permutations of updmap and updmap-sys, with no change. I can see a whole load of map files in my texmf-var directory, but no idea what to do with them to make them available to the builder.

I'm not sure if this is a server config issue or a pdflatex issue. Is it possible to tell pdflatex to use fonts from a specific location?

Edit: Another question led me to the command kpsewhich pdftex.map, with the output:


So, I created a folder called $HOME with a soft link from .texmf-var to the .texmf-var folder in my home folder, and the thing works! This isn't a great solution, and I'm sure there's a better way, so please do help if you can!

  • 2
    How are TeX and the fonts installed on this system? Distribution-maintained packages, installing TeX Live from upstream media, or what? I suspect you have at least a few things installed in your account that aren't available to other users, including the Apache user. Apr 22 '13 at 16:22
  • All from distro, Ubuntu desktop.
    – Dave Child
    Apr 22 '13 at 17:05
  • 1
    You probably have run updmap from your account, which is usually bad. However kpsewhich pdftex.map will never show $HOME in its output, so I guess something very wrong has been done to your distribution.
    – egreg
    Apr 22 '13 at 18:07

I moved my build process onto a fresh install of Ubuntu and still had the same problem. In the end I installed the "texlive-full" package, and that sorted it out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.