20

I'm using IEEEtran to format an article, and I wanted to include an image. I included the graphicx and hyperref packages, and used the following code, like normal, to include an image.

\begin{figure}[!t]
\centering
\includegraphics[width=3in]{fetch}
\caption{Pipeline: Fetch Instruction}
\label{fig:fetch}
\end{figure}

What appears, however, is this:

Example

Fetch.png is a file in the directory, and if I remove it, pdflatex errors instead of producing an output. I'm using MiKTeX 2.9 on Windows 7. Any ideas?

2
  • 1
    Are you using the draft document option?
    – Caramdir
    Feb 13, 2011 at 18:49
  • Sean, I included the image for you. You have now over 10rep so you can do it now by yourself as well. Feb 13, 2011 at 19:17

2 Answers 2

31

You have the draft option enabled, most likely as class option, which makes graphicx to display images like this. Load graphicx with the final option to overwrite this. Note that options of the class are global and are passed to all packages, but can still be overwritten by explicit package options.

3
  • This was it. Silly me!
    – user3561
    Feb 13, 2011 at 19:20
  • Oh man you saved me!!! Sep 2, 2017 at 22:51
  • Thanks a million! Happened to me as well, but for the Springer template. Thanks to all the great publisher for documenting their templates extensively! May 16, 2023 at 7:03
0

It happened the same to me. In my case I was defining the folder to get the pictures on top of the document through the command: \graphicspath{ {./images/} }. But when I was asking the picture to be put in the document ,I was again specifying the folder, so I removed the folder and it worked.

You must log in to answer this question.