2

I am writing my PhD thesis with ClassicThesis, in LyX under Linux. Everything is working perfect... until I noticed that the order of apperance for my references is off. For example, the first listed reference in the text is reference 48 (and not 1), so the list of references is in another order than they were referred to. This of course looks... Bad to say the least. I have tried passing unsrt to natbib, tried unsrt, unsrtnat as bibstyles (Using biblatex, but with the bst file for Angewandte Chemie journal). Nothing happens, I have changed everything everywhere but the references still come in the wrong order. Anyone? Please? :)

  • Welcome to TeX.sx! – Peter Jansson Apr 25 '13 at 16:19
  • It would probably be useful if you posted a LyX minimal example (wiki.lyx.org/FAQ/MinimalExample) and exported that minimal example to LaTex and posted that as well. – scottkosty Apr 25 '13 at 21:20
  • Also, which LyX version do you use? – scottkosty Apr 25 '13 at 21:22
  • 1
    LyX 2.03. The problem seem to have something to do with the layout of multiple files and includes. I am really sorry, but not very familiar with neither LyX nor LaTeX. All my chapters have a LyX-note with a BiB in order to add citations, then a final "chapter" with a Reference list. Then all is encoded from a large file which includes all chapters plus the reference file. However, If I separately take one chapter file and instead have the Bib as a "hidden" LyX-note and add the Reference list immediately after, it arranges in the correct order?! But I don't want a reference list for each chap. – Jonas Apr 26 '13 at 11:36
  • To clarify: At one point you mentioned "Using biblatex", but the tag "bibtex" suggests that you are using "bibtex". So are you using the "bibtex" (the default in LyX and ClassisThesis) or did you change to "biblatex" (then you must have put \usepackage{biblatex} somewhere...)? BTW, you can edit your question to correct the wording or the tags. – e-birk Apr 27 '13 at 14:47
2

General Remark: The port of ClassisThesis (v4.1) to LyX does not seem to be complete yet.

Probably the reason is that the main document ClassisThesis.lyx contains under "Document Settings... > Bibliography" the citation style "Natbib". Set this to "Default (Numerical)". Natbib will still be used because of

\PassOptionsToPackage{square,numbers}{natbib}
  \usepackage{natbib}

in the file classicthesis-config.tex. (Alternatively, you could remove these lines and leave the setting in LyX on "Natbib".)

Furthermore, looking at the file Bibliography.lyx (of the default Classisthesis archive) I can see the TeX code/ERT

%\bibliographystyle{plainnat} %%%%% LyX will do this

in front of the "BibTeX Generated Bibliography". Leave this as is and right click on "BibTeX Generated Bibliography > Settings..." and change the style to "unsrtnat".


If "unsrt" is used then I saw that the citation via the author name - that corresponds to \citeauthor in LaTeX - does not work.

Looking at the generated LaTeX code (via "View > View Source", "Complete Source") might help to spot any duplicated entries. In the case of Bibliography.lyx you would see this (which is okay since % denotes a comment):

%\bibliographystyle{unsrtnat} %%%%% LyX will do this

\label{app:bibliography}

\bibliographystyle{unsrtnat}
\bibliography{Bibliography}
  • Thanks for all your help! Tried everything, to no avail. However, I realised one thing. My thesis is build of two parts (with few chapters each), and I want a reference list in the end of each part. Now that I look on my old copy where the second reference list was not included all the references are in order?! To have separate bibliographies I simply have a include for a ClassicThesis Bibliography.lyx-file in the end of each part, which points to different BibTex-files. And suddently all references are disordered. :( – Jonas Apr 27 '13 at 7:31
  • So, basically my setup is: 1 main file whichi includes chapters, divides into 2 part with each part ending with a reference file. If I disable "Sectioned Bibliography" in all three files, the references are included for the first part and are in correct order, the references for the second part are "???". If I enable "Sectioned Bibliography" in all three files, all references and reference lists are included but the order of the references are mixed (the are citated correctly, but the first reference is numbered 47, 2, 13 etc.... – Jonas Apr 27 '13 at 7:45
  • I realise this all sounds very confusing (I am stressed, submitting on monday :)). Basically: When used sectioned bibliographies in lyx (Options->Bibliography->Sectioned Bibliograph) two have one reference list each per part of the thesis, the references are ordered weirdly. With only ONE bibliography in the end everything looks fine (without doing any other changes). – Jonas Apr 27 '13 at 10:28
  • @Jonas It is difficult to help without seeing any LaTeX code ("View Source") or the LyX document. I based my suggestions on ClassicThesis-LyX-v4.1.zip from here. – e-birk Apr 27 '13 at 15:03
  • @Jonas Your last comments are about a different question: How to create separate bibliographies in your document. Hence, you should ask this in a new question. – e-birk Apr 27 '13 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.