I want to use the "show notes on second screen" option for beamer. Here's my code (MWE):


\setbeameroption{show notes on second screen}

\author{Todd Hester}
\institute{University of Texas at Austin}
\date{December 3, 2012}



\frametitle{Robot Learning}
\item Robots have the potential to solve many problems
\item Moving from controlled to natural environments is difficult
\item We need methods for them to learn and adapt to new situations
\note{Robots have the potential to be very useful in society, by doing tasks that no one wants or is able to do. However, they are currently limited by the need to hand-code them for most tasks. Therefore, we need methods for them to learn from experience in the world.}


When I try to compile, I get:

! Undefined control sequence.
\KV@beamer@option@show notes on second screen ... 
                                              {two screens with optional...
l.5 \setbeameroption{show notes on second screen}

Here are the versions from the top of the compile output:

This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/Debian)
restricted \write18 enabled.
entering extended mode
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, uk
english, loaded.
Document Class: beamer 2010/06/21 development version 3.10 A class for typesetting presentations (rcs-revision a6b1a8434d30)

1 Answer 1


The preamble should be:


\setbeameroption{show notes on second screen}

i.e. pgfpages rather than pdfpages

See the Beamer User Guide sections 19.6 and 22.

  • it is still not working although \usepackage{pgfpages} is loaded
    – shacts
    Commented Nov 10, 2020 at 10:47
  • 1
    @shacts You should open a separate question with your MWE and explain what does not work.
    – d-cmst
    Commented Nov 11, 2020 at 13:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .