2

I'm using the report document class and the chapter titles are very large, in bold font, and left justified. I need them to be 18pt, not bold, and centered. I also need the words 'chapter 1' to be centered above the chapter title. My preamble and chapters look like this:

\documentclass[12pt]{report}
\usepackage{graphicx}
\usepackage{fullpage}
\usepackage{setspace}\doublespacing    % important!
\textfloatsep 0.75in                   % important with double spacing




\begin{document}

\chapter{chapter title}

\end{document}.

I have tried modifying as follows:

\centerline{\chapter{chapter title}}

or

\begin{center}
\chapter{chapter title}
\end{center}

but I don't think this is going to work...

Their are lots of posts related to this topic but I can't make sense of which exact parts to use for my application. Please help with my specific case.

2

1 Answer 1

1

You can achieve this by using titlesec package and \titleformat command:

\titleformat{\chapter}[display]{\Large\centering}{Chapter \thechapter:}{0pt}{}{}

where you choose what command to modify (\chapter), use vertical mode with zero spacing (display and 0pt) and set font and centering (\Large is a 18 pt?).

Full listing:

\documentclass[12pt]{report}
\usepackage{graphicx}
\usepackage{fullpage}
\usepackage{setspace}
    \doublespacing
    \textfloatsep 0.75in

\usepackage{titlesec}
    \titleformat{\chapter}[display]{\Large\centering}{Chapter \thechapter:}{0pt}{}{}

\begin{document}

    \chapter{chapter title}

\end{document}
2
  • thank you for the clear and concise answer. I figured toe chapter titles now and I'm working on the section titles. I include the following in my preamble. \usepackage{titlesec} \titleformat{\chapter}[display]{\centering}{CHAPTER \thechapter}{0pt}{}{} \titleformat{\section}[display]{}{\thesection}{0pt}{}{}. Now the section label (3.1 for example) and the section name (abstract for example) appear on different lines. How to fix...?
    – user29753
    Commented Apr 26, 2013 at 19:12
  • @user29753: Just remove the [display] for \section, this option enables vertical "mode".
    – m0nhawk
    Commented Apr 26, 2013 at 19:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .