I'm trying to have a tabulary-table on a landscape page in a portrait document.

Because I want to have the table use the full width, I tried to set it width to \textwidth, but the width of the table is only as wide as the textwidth is on a portrait page.

How can I make the table using the correct width?

Since I am using XeLaTeX the MWE contains Unicode-Characters!


\title{MWE – tabulary rotate}
\subtitle{Textwidth is way to small}
\author{John Doe}
\emph{Left} & \emph{Middle} & \emph{Right} \\
This is a text that shall be a litte bit longer, and longer!
& And even this text is meant to be not so short that it is just simple short…
& Also there is the last column, which shall not be just a handful of letters
but an full sentence instead, that doesn't not even to make sense!

1 Answer 1


\linewidth can be used instead:


Package lscape does rotate \textheight, but does not change \textwidth. Probably a bug.

Update: It is a design compromise, see David Carlisle's comment.

  • 3
    not a bug, just a design compromise. lscape doesn't rotate the page head/foot and if you change \textwidth many settings of the page head went wrong. \linewidth is normally used within the page so it was safer to set that. Apr 26, 2013 at 20:14
  • @DavidCarlisle Thanks for the clarification. Apr 26, 2013 at 20:21
  • Oh +1 for giving the right answer:-) Apr 26, 2013 at 20:21
  • @DavidCarlisle - Is there a method to avoid the resulting overfull \hboxes?
    – kando
    Sep 3, 2015 at 22:34
  • @kando there are no overfull hboxes that result from this answer. If you have overfull boxes perhaps some text doesn't fit something but you should open a new question, not in a comment on an old answer, and give an example that demonstrates the problem. Sep 3, 2015 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.