1

I am experiencing difficulties with installing imsart package.

I am using Windows 7, 64-bit system. My TeX directory look like this:

C:\Program Files (x86)\MiKTeX 2.9

and

C:\Program Files (x86)\TeXworks,

but this one is not relevant, this is just an editor.

There I installed files from the link above into three different destinations, three newly created directories imsart:

C:\Program Files (x86)\MiKTeX 2.9\imsart
C:\Program Files (x86)\MiKTeX 2.9\tex\imsart
C:\Program Files (x86)\MiKTeX 2.9\tex\latex\imsart

I replaced the header \documentclass{article} by \documentclass[aap]{amsart}

However, the compiler says:

File `imsart.cls' not found.
Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: cls)
Enter file name: 

In an attempt to overcome this problem, I integrated root directories.

I registered MiKTeX 2.9 as a user-managed texmf directory.

This did not work.

  • 1
    To get things working initially just put all the files in the same folder as your document. If you install them in the tex path directories you will need to do the miktex equivalent of texhash to update the search database (which won't be hard but I don't know miktex so can't tell you exactly) But placing the files in the working directory should always work. – David Carlisle Apr 26 '13 at 20:42
  • Thank you sir, this works, and I have resolved the problem. – Andrey Sarantsev May 8 '13 at 0:10
  • Full details about doing a 'proper' local install in MiKTeX are in the question I'm duping to. (If the question is still in need of more attention, flag and I'll reopen.) – Joseph Wright Aug 14 '13 at 20:22

Browse other questions tagged or ask your own question.