After seeing Herbert's answer, apparently this problem should not occur if I realized the first row of the following code should be \documentclass{beamer}. Problems often come from not knowing what I am doing.

Please close this too localized question.

Sorry for the bad title!

% ========================================================
% Copyright (c) 2013 Bugbusters. All rights reservered.
% LPPL LaTeX Public Project License
% ========================================================
\ProvidesPackage{pst-sex}[2013/04/23 v3.141592654 Constant declator for StackEXchange]

% removing a trailing space in the original fp.sty
    % #1 macro, which gets the result
    % #2 base
    % #3 exponent

% constants declarator
    \edef\LoadConstants{\the\toks0 {/#2 \csname#2\endcsname\space def}}}

% inject \LoadConstants into pspicture
        \pstVerb{/##2 \csname##2\endcsname\space def}\ignorespaces}%
    \@ifnextchar(% ignore anything between [] and ()

% pst-sex.sty


\const{Side}{root(2,17)}% the square root of 17

    \psframe(!Side dup)\pause
        \rput{\i}(!Side 2 div dup 2 copy temp mul add 3 1 roll \i\space sin mul add){$\temp$}\pause

What causes this error?

closed as too localized by Werner, Marco Daniel, Mensch, mafp, Thorsten Apr 27 '13 at 13:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Sorry for the bad title because I have no idea to make it more specific and descriptive to convey the exact issue. So feel free to edit the title to suit your preference. :-) – kiss my armpit Apr 27 '13 at 7:02
  • 2
    I think you should try to minimise your code -- remove any lines that can be removed while preserving the error. For instance, I just tried removing everything between \begin{pspicture}(\Side,\Side) and \end{pspicture} and the error was still the same. This way you might be able to zoom in on the source of the error. – John Wickerson Apr 27 '13 at 7:28
  • @JohnWickerson: The problem has been fixed. It is about my fault. I used article that should be beamer. – kiss my armpit Apr 27 '13 at 7:50
  • Most "bugs" with LaTeX system are user problems. – kan Apr 27 '13 at 7:51
  • @kan: And bugs come from not knowing what we are doing. – kiss my armpit Apr 27 '13 at 7:53

it maybe a good idea to choose the correct documentclass ;-)

[ ... ]

but you are using the frame environment ...

However, with the current pstricks.tex from http://texnik.dante.de/tex/generic/pstricks/ I can do something like:


 \psframe(+{-sqrt(17)/2}, x)(+{sqrt(17)/2}, x)\pause
 \multido{\iA=0+30}{12}{\rput{\iA}(1;\iA){\psPrintValue[algebraic]{\iA, cos(x*Pi/180)}}\pause}

enter image description here

  • Adding a new feature to allow points in all PSTricks graphic objects to accept node expressions is a good idea. For example: \pnode(2,3){A}\pnode(3,1){B}\psline(.5(B)-.25(A))\rput((A)-(B)){...}\pscircle(2(B)-3(A)){3}. :-) – kiss my armpit Apr 27 '13 at 8:08
  • There is a typo in pstricks.tex (click me). – kiss my armpit Apr 27 '13 at 18:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.