I just installed ST3 and installed the LatexTools package using Package control. Everything seems to have gone fine except when I compile using CMD+b nothing seems to happen. On the terminal I get the following error:

Unable to find target command: make_pdf

I am not being able to understand the error. Can someone please help?

  • The best solution would be to contact the author and mainter of LatexTools package on GitHub github.com/SublimeText/LaTeXTools – Guido Apr 28 '13 at 3:56
  • @sepehr, Thinker: Welcome to TeX.sx. Please note that this Q&A site does work differently than a forum. Please only use answers for solutions to the question and not for "me too" and other things. Such things can be posted as comments, once you get 50 reputation. You can always comment on your own posts and answers to your own questions. – Martin Scharrer Apr 29 '13 at 19:25

Heads up: there is now a branch of the "official" LaTeXTools package that supports ST3. See http://tekonomist.wordpress.com for details. The code is based on phyllisstein's port but incorporates all recent fixes to the master branch.

Let me know how it works for you, and please report any issues on GitHub (there is an issue specifically for ST3 problems).

Marciano (LaTeXTools author)

| improve this answer | |
  • Hi,I tried for follow the instruction but, got the following error:This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012) restricted \write18 enabled. ** ! End of file on the terminal... why? [Finished in 0.2s with exit code 1] [shell_cmd: pdflatex – Thinker Jul 6 '13 at 10:04
  • Hmm... not sure. Are you compiling using the Ctrl-B (Cmd-B on OSX) keybinding? – Marciano Siniscalchi Jul 6 '13 at 21:16
  • Yes, I am using the Cmd+B binding on Mac. The same works perfectly for Sublime Text 2 on the same machine – Thinker Jul 7 '13 at 23:45
  • Any news? Have you tried pulling the latest update? I've tested on both Mac and Windows and things work just fine for me... – Marciano Siniscalchi Jul 20 '13 at 6:02

I was struggling with the exact same problem, and this was one of the few Google-hits on your error message.

As far as I understand, what is happening is that the original LaTeXTools uses ST2's Python 2.7, while ST3 uses Python 3. So here's a solution.

  1. I had to start with a Sublime Text 3 (ST3) installation completely free of any LaTeXTools installation.
  2. Clone phyllistein's unofficial port of LaTeXTools for ST3 using git, placing it in Sublime Text 3/Packages. (In the terminal go to the correct folder and type git clone https://github.com/phyllisstein/LaTeXTools)
  3. If needed, restart ST3.

TeX ahead! Please note that if you update this plug-in via Package Control before an official release of ST3 support, you might reproduce your original error message.

EDIT: There's also another plugin for Sublime Text 2/3: LaTeXing. Haven't gotten myself around to try it, but it looks promising =)

EDIT 2: I have now ported completely to the LaTeXing plug-in. It is awesome!

| improve this answer | |
  • Still getting error. Any ideas how to solve this:This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012) restricted \write18 enabled. ** ! End of file on the terminal... why? [Finished in 0.2s with exit code 1] [shell_cmd: pdflatex – Thinker Jul 6 '13 at 10:05
  • 1
    Never seen that one before. More suitable as a new question perhaps, if it does not directly relate to your original post? – Holene Jul 6 '13 at 16:37
  • 1
    I can confirm that the make_pdf issue is solved in the official release, for more details see Marciano Siniscalchi's answer: tex.stackexchange.com/a/122414/16419. – Gerhard Burger Jul 8 '13 at 15:22

I had the message:

Unable to find target command: make_pdf

after I had successfully installed the LatexTools package on ST3, and had the build command working. However, after restarting my system on mac OS X, the build command no longer worked.

The solution in this case was to restart ST3 from the terminal command line using


| improve this answer | |
  • 3
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Symbol 1 Jul 14 '15 at 3:53

In my case, this issue was apparently solved by deleting temporary files. This can be done manually or by choosing "LatexTools: Delete temporary files" in package control.

| improve this answer | |

I had the same problem. In my case, it's because I also installed LatexTools package. How to solve it: Go to

Tools > Build System > LaTeX

There will be two "LaTeX" submenu. Just try both. In my case, the make_pdf is the first "LaTeX" and pdflatex is the second "LaTeX". Since I use MiKTeX, then pdflatex works for me, then I choose the second "LaTeX" submenu.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.