8

Is it possible to reduce line spacing in the Table of Contents?

I have tried adding \singlespacing before the TOC but I get "Undefined control sequence"

I have also tried \setlength{\itemsep}{0mm}

11

try setting in the preamble \usepackage{setspace} and after \begin{document} write \addtocontents{toc}{\protect\setstretch{0.9}} (needs Ctrl-L for the TeX mode.

You can decrease the number to any value you need.

Another possibility is to set the additional space to zero:

\begingroup
\def\addvspace#1{}
\tableofcontents
\endgroup
| improve this answer | |
  • This works! However, the spacing between Parts and Sections is still quite big even when setting \setstretch{0}. Can it be decreased any further? – liarspocker Apr 28 '13 at 22:03
  • @user29762: see my edit for another solution – user2478 Apr 29 '13 at 7:24
3

From other posts I guess that you are using the article class where the spacing is large.

In contrast, for the report class or a similar class like scrreprt, the spacing between TOC entries is about single spaced. Hence, one solution (and my suggestion) would be to switch to the report class......

(There are some comparisons: Regarding the `book`, `report`, and `article` document classes: what are the main differences? and Section numbering in article vs. report class)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.