This question already has an answer here:

I'm writing in LaTeX a scrreprt onesided document, for which I would like to number the pages on the right side of the footer (don't need anything more in the footer). I've found this:


this is exactly what I need, but the right enumeration is only within chapters from the second side, on the first page of every chapter it doesn't work and default is used (number in the middle of the footer)

Do you have some ideas how to fix it?

marked as duplicate by Werner, Thorsten, Mensch, Charles Stewart, Martin Schröder May 1 '13 at 16:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome to TeX.sx! – Peter Jansson May 1 '13 at 15:55
  • Werner is right, that question contains yours. The problem is that the \chapter macro resets page style, so you need to reissue it. – Charles Stewart May 1 '13 at 16:39


  • this is very helpful, but do u know how to delete this line above? – Wiktor Olszowy May 1 '13 at 15:53
  • What line? Please, show us a minimal code. – Sigur May 1 '13 at 15:57
  • @user2339479: In the link you provide it mentions \renewcommand{\headrulewidth}{0pt} which is meant to remove the rule in the header. Since \chapter page styles are plain by default, setting it to fancy this way (with all the details included in your link) should leave you without a line in the header/above. – Werner May 1 '13 at 16:08
  • @user2339479, based on the comments above, I understood now. I was supposing that you were using all the commands from that link. – Sigur May 1 '13 at 16:12
  • sorry, indeed this question has already been asked; my mistake after the suggestion to use \chapter{title}\thispagestyle{fancy} was that I didn't use the code I'd found earlier, now everything works, thanks! :) – Wiktor Olszowy May 1 '13 at 18:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.