2

I use following code:

\begin{center}
\begin{tabular}[]{llcl}
\hline
\rowcolor[gray]{.9}\textbf{Parameter} & \textbf{Description} \\\hline
-c, --create & Do something\\\hline
\end{tabular}
\end{center}

So after I created the PDF document, the "--" is converted to:

-create

Is there any possibility to fix that, because I need both "-".

  • 2
    Add an empty group between the two hyphens: -{}- – lockstep May 3 '13 at 8:03
  • You can avoid XeTeX joining the two hyphens into an en-dash by loading the font without the Ligatures=TeX option. – egreg May 3 '13 at 9:25
2

Just add an empty group between the two hyphens:

   \begin{center}
    \begin{tabular}[]{llcl}
    \hline
    \rowcolor[gray]{.9}\textbf{Parameter} & \textbf{Description} \\\hline
    -c, -{}-create & Do something\\\hline
    \end{tabular}
    \end{center}

Thank you lockstep for you answer!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.