I'm using MiKTeX 2.9 under Windows XP. I have the following directory structure for my document:

  • D:\MyTeX
  • D:\MyTeX\BibTeX
  • D:\MyTeX\IPMcast

File latexmkrc contains the line:

$bibtex = 'bibtex -include-directory=D:/MyTeX';

File IPMCast\ipmc.tex contains the line:


When I use the command:

latexmk -r latexmrc ipmc

my document is created minus the BibTeX references.

When I manually use the commands:

latex ipmc
bibtex -include-directory=D:/MyTeX ipmc
latex ipmc
latex ipmc

files ipmc.bbl and ipmc.blg are created and my document is properly created with references.

I have tried several variations of latexmkrc using apostrophes, quotation marks, back slashes, forward slashes, etc with no luck. The original document was created in 2007 and I believe everything worked properly then. How should I define $bibtex in latexmkrc file to get this to work?

  • @Martin: I had already been wondering why you of all people didn't use <pre> tags :-) A tip: If you repair an edit within the 5 minute grace period, then the new Edit Summary will overwrite the previous one. (Have a look at the revision history!) Feb 16, 2011 at 14:21
  • @Hendrik: I just found that out by myself! :-) The problem is that I still had my old Greasemonkey script on which also highlights normal <pre> tags. Feb 16, 2011 at 14:22

1 Answer 1


I look at the man page again and found the solution. The call should be:

latexmk -bibtex -r latexmrc ipmc

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .