2

I'm writing a report with lyx 2.0.2 and I want to insert in the end a webography which is the same as bibliography but its called webography instead. So what I want basically is either to change the bibliography to webography, or if there's another way of inserting a webography in my report.

update:

Well it's not exactly like a bibliography, the references in the webography are just urls.

update 2:

Actually, I don't just want to change the heading of the bibliography to 'Webography' I want to change the behavior too, 'Webography' will contain references for Urls, just Urls not like bibliography author, and other stuff.
And I'm using the report class.

update 3:

I have this in the head of the lyx document:

\newpage\pagestyle{fancy}\lhead {ISI}\lfoot{Shiny development}\renewcommand{\footrulewidth}{0.4pt}\cfoot{}\fancyfoot[R]{\thepage}
\makeatletter  
\let\ps@plain=\ps@empty 
\makeatother
\widowpenalty=10000 
\clubpenalty=10000 
\raggedbottom  
\pagenumbering{arabic}

And now after trying @Torbjørn's answer, I keep having this error:

! Package natbib Error: Bibliography not compatible with author-year citations.

And putting the cursor at this line:

\makeatother

And that happen even when I try to see the DVI version and when I remove the bibliography everything works fine.
By the way this is my first time writing something with lyx or latex.

3

You can create a 'webography' with the thebibliography environment and the \url command. To redefine the name, you can use the techniques described in How to change the name of document elements like "Figure", "Contents", "Bibliography", "Appendix", etc.?, but it seems a small change must be made due to how LyX loads packages (specifically, babel).

Adding the list

Where you want to have this webography, choose the Bibliography-element from the drop-down menu in the top left. This will add a thebibliography environment to your document, and it will look like this:

enter image description here

Place the cursor right after the key-1 [1] inset, and choose Insert --> URL. Type a URL in the box that appears. To add a new URL to the webography, move the cursor outside the URL-inset, and hit enter. Finally, you can change the label (key-N) by clicking it.

Changing the heading

LyX loads babel by default as far as I know, so in How to change the name of document elements like "Figure", "Contents", "Bibliography", "Appendix", etc.? it is the 'With babel' section that is relevant, but with a small change. Add the following to Document --> Settings --> LaTeX Preamble:

\AtBeginDocument{%
  \addto\captionsenglish{%
    \renewcommand{\bibname}{Webography}
  }}

If English is not your chosen language, you have to change that.

The reason for the \AtBeginDocument is that when I tried this, LyX added babel to the very end of the preamble, the stuff you add to the preamble yourself is placed before the loading of babel. Therefore, \addto\captionsenglish is not available at the time it is used, but with AtBeginDocument the use is postponed until after the entire preamble.

Note that the heading will not change within LyX, but it will change in the PDF.

enter image description here

Don't use natbib

LyX seems to behave a little silly (or maybe it's just me), so in Document --> Settings --> Bibliography, make sure that Default (Numerical) is selected, and not Natbib.

  • Hi, thanks for answering but I got some errors, check update 3. – Yahya KACEM May 4 '13 at 21:45
  • @YahyaKACEM See my update. – Torbjørn T. May 4 '13 at 21:54
  • That did it but now I get this (author?) [1]: in the place where I want to put the citation, how to remove this. – Yahya KACEM May 4 '13 at 22:36
  • @YahyaKACEM Oh, damn, sorry about that. Try with Default (numerical) instead of Natbib. – Torbjørn T. May 4 '13 at 22:40
0

You can change the heading of your bibliography by inserting a ERT element (Insert→TeX) right before the bibliography with the following command: \renewcommand\refname{References } or \renewcommand\bibname{References}, depending on whether you use an article or a report/book class.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.