I installed MiKTeX Basic on Windows XP Professional (v. 2002, with Service Pack 3) (32) (at work), but it keeps crashing when I try to look up updates or install packages. It seems to not be able to find package repositories.

It seems like it can't find any package repositories. When I try to install a package on the go, the Package Installation window says "The package will be installed from": . If I try to change it, the Change Package Repository window shows an empty list when I'm supposed to select a new one. Moments later it crashes.

I've tried installing them using the Package Manager, and while it does find the packages, when I hit "install", the downloading window opens but the statistics number boxes are empty (nothing's happening). Then it crashes. I've tried both the Admin and non-admin versions.

It's very similar when I try to look for un update. I get to the Update MiKTeX window, choose "Use the nearest package repository" and click Next, then it just freezes and crashes.

I've installed and uninstalled the Basic version several times, and have rebooted my computer as well. I tried the Complete version as well, but there was an error (Windows API 1113). The errors are the same whether I have admin rights or not.

I also tried downloading some packages from http://ctan.org/tex-archive/systems/win32/miktex/tm/packages/ onto my computer and setting that as the local package repository but it tells me "Not a local repository".

Without any extra packages I'm able to compile a basic Hello World.

  • 1
    Welcome to TeX.SX! Here's a starter guide Commented May 7, 2013 at 6:28
  • When you run the Package Manager, are you using the Admin version? If not then try running that version. It is located in the Maintenance (Admin) folder. It is just not clear to me if you have done so. Commented May 7, 2013 at 6:32
  • Yeah sorry I forgot to mention that. I've tried both the Admin version and non-admin (while I had admin rights). Same thing with the Updater. Commented May 7, 2013 at 6:39
  • 1
    Welcome to TeX.sx! Usually, we don't put a greeting or a “thank you” in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say “thank you” to users who helped you. Commented May 7, 2013 at 6:43
  • 1
    For a local repository you need also the two files starting with miktex-zz Commented May 7, 2013 at 13:46

1 Answer 1


I cannot solve your problem, BUT... If you need MikTeX immediately, then try using the portable version instead. If you are the only user (others at work do not need it), then you might consider placing it in a location where you can take full ownership rights (your user home directory?), if that is the problem.

As far as I can tell, the portable version works just the same as the installed version. The main difference is that the installed version will put your user customizations wherever Windows chooses to put them (depends on your OS configuration, might be hidden such as C:\Users\You\AppInfo\Roaming\MikTeX29) but in the portable version you can choose your own place to put your customizations, which should be a folder parallel to the MikTeX installation and with full user rights. Actually, how I did it was to first install to USB, get things working, then copy into my user directory. That seems to set permissions automatically (it did for me; your results may differ).

On the other hand, if all repositories are down, that would be a different issue. EDIT: I was able to run the updater and get a few updates just now. So the repositories seem to be OK.

  • It turned out it was a problem with my company's security settings, something must have blocked the installer when it tried to go online. The case is closed, I got everything running. It's a little unclear to me what I should do now - do I accept RobtA's answer even though it didn't technically solve my issue? Commented May 16, 2013 at 11:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .