An example of a BiBTeX reference of mine

  author = {{Craig M. Pratt and Terry Eaton and Marilyn Francis and Antonio Pacifico}},
  title = {{Ambulatory  Electrocardiographic Recordings: The Holter Monitor}},
  journal = {{1988 Year Book Medical Publishers Inc.}},
  year = {1988},
  owner = {larselgaardmikkelsen},
  quality = {1},
  review = {hvad er en holter monitor},
  timestamp = {2013.05.06}


Craig M. Pratt and M.D.n Terry Eaton and R.N. and Marilyn Francis R.N. and Antonio Pacifico, M.D., “Ambulatory Electrocardiographic Recordings: The Holter Monitor,” 1988 Year Book Medical Publishers Inc., 1988.

How do I move the comma at the end of the title, so that it is outside the title? I have "title," and I want "title",. Added the following as a minimal example This is my master.tex (shortened version)

\pagenumbering{roman}% Page number in roman style

I am using Memoir. And this is from my preamble:

\usepackage[utf8]{inputenc} % Input encoding - Depending on editor
\usepackage{lmodern} % Modern LaTeX font
\usepackage[english]{babel} % Language package
\usepackage[T1]{fontenc} % Hyphenation
\usepackage{fix-cm} % Fix for cm
\usepackage{graphicx} % To handle pictures
\usepackage{tikz} % Graphical tool
\usepackage{mathtools} % To use \eqref
\usepackage{url} % Use of urls in the text
\usepackage{varioref} % Smarter references
\usepackage{calc}% Auto calculate
\usepackage{lipsum} % Debugging text
\usepackage{sansmath,subfig} % Gives a warning because subfig loads caption

Hope this is better - if not please let me know.

  • 3
    you're not telling us what tools you're using to produce your bibliography: what engine, what style files, etc. Could you provide a minimal working example? Otherwise noone will be able to reproduce your problem. – Nils L May 7 '13 at 14:13
  • 2
    A separate comment: The bibliographic entry doesn't seem to be well suited for the @article entry type; e.g., there's no volume number, no issue number, no page(s). It may be better suited for the @inbook entry type, where you'd replace "journal" with "booktitle". Furthermore, you should really remove one set of curly braces around the contents of the author field, so that BibTeX can format them in conformance with whatever \bibliographystyle that you may have chosen. – Mico May 7 '13 at 14:36

This behavior is hardcoded in your bibliography style ieeetr. The relevant function is

FUNCTION {format.title}
{ title empty$
    { "" }
    { "``" title "t" change.case$ * ",''" * }

If you change that into

FUNCTION {format.title}
{ title empty$
    { "" }
    { "``" title "t" change.case$ * "''," * }  %% moved comma out

you get the desired output. But please make a copy of ieeetr.bst for such edits, and call it, say, myieeetr.bst.

Of course, there is always the option to use a different bibliography style.

| improve this answer | |
  • I don't seem to have a ieeetr.bst file - i have my tex files and a folder with a bib file. I using a Mac computer, and the program TexPad. – jens May 8 '13 at 14:39
  • @jens In your code you are using \bibliographystyle{ieeetr}, so the ieeetr.bst has to be somewhere. I have mine in the TEXMF tree under bibtex/bst/base/ieeetr.bst – mafp May 8 '13 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.