I want to position page numbers in my document in top-right corner. I managed to do so using fancyhdr (see below).

    pdfborder = {0 0 0}

Everything works fine, except page number on the page where I have table of contents is centered at the bottom of that page.

Does anyone know how to fix that?

  • 1
    Welcome to TeX.sx! Your post was migrated here from another Stack Exchange site. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question.
    – jub0bs
    Commented May 7, 2013 at 15:11
  • 1
    Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – jub0bs
    Commented May 7, 2013 at 15:11

1 Answer 1


I believe you need to edit the plain settings. For example, adding the following to the preamble may help

\fancyhf{} % clear all header and footer fields
\fancyhead{} % clear all header fields
\fancyfoot{} % clear all footer fields

Note that in the fancyhdr documentation it says that

Some LaTeX commands, like \chapter, use the \thispagestyle command to automatically switch to the plain page style, thus ignoring the page style currently in effect. To customize even such pages you must redefine the plain pagestyle.

Therefore, this includes pages like the Table of Contents.

  • @marmelade You are most welcome!
    – azetina
    Commented May 9, 2013 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .