I am using MiKTeX 2.9 on an XP account with restricted user rights. Unfortunately I was not able to compile a file under xelatex which included pstricks graphics, so I tried everything that I found on the net, i.e. updating all packages and adding a -dNOSAFER option to the file dvipdfmx.cfg. These thing were done under an administrator account, after I found out that the problem persisted there as well (I am not the administrator, by the way). Happily this seemed to work - I was then able to compile the file . However, when trying to compile under my restricted account, I get the well-known message again:

** WARNING ** Image format conversion for PSTricks failed. 
** WARNING ** Interpreting special command pst: (ps:) failed.
** WARNING ** >> at page="1" position="(133.768, 372.249)" (in PDF)
** WARNING ** >> xxx "pst: tx@Dict begin STP newpath /ArrowA { moveto } def /ArrowB "

This is a minimal example:

\rput(2,2.5){An Example}

I'm really wondering what's going on here. Unfortunately I don't know much about user rights on XP and how they might interfere with xelatex. Switching to LaTeX/pdfLaTeX is not an option for me, as I need the unicode support provided by XeLaTeX. I'm happy for any suggestions.

Edit: I would like to add that I added the -dNOSAFER option directly to the dvipdfmx.cfg (I know one is not supposed to do so as it might be overwritten), because when I first put the edited file into my local repository I did not notice any change in behaviour, although I refreshed the FNDB and updated the format files after placing the file there. Anyway, now that I think about it, when I first put it into the local repository I did so under my restricted user account whereas when I edited the original file I was logged in under our administrator's account (which I cannot access without our admin's help). So the reason it did not work was probably not due to the location of the file but rather to the user rights issue. However, I would prefer to have the adjusted file under my local repository, in case I really need it.

  • Try to make a trivial simple input file with just a period and compile with xelatex, does it work? May 7 '13 at 16:20
  • Yes, that works. Actually in the above example all text would be displayed, but all lines are missing.
    – Elisa
    May 7 '13 at 16:23
  • 1
    Welcome to TeX.sx! May 7 '13 at 16:32
  • Try to compile your code above with pdflatex -shell-escape and make sure you load \usepackage{auto-pst-pdf}. Does it work? May 7 '13 at 16:36
  • Hm, it says "No pages of output.", but at least it creates an autopp.pdf that shows the desired output.
    – Elisa
    May 7 '13 at 16:43

I had to experiment for a while before I found a solution that worked for me. Here it is:

  1. Log in to your restricted user account.
  2. In the Start Menu, go to MiKTeX 2.9 --> Maintenance (Admin)
  3. Right-click on Settings (Admin) and choose Run as...
  4. Open the program as an Administrator (the Admin will have to type in his Admin password)
  5. Click Refresh FNDB and Update Formats under the General Tab.
  6. Save and close the program

That's all. I don't know what happens at step 5 when the Setting program is not run with root permissions, but at least I'm not getting any PSTRICKS warnings anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.