106

For some reason, my figures get pushed to the end of the document. I tried begin{figure}[t], [h] and other options, but none helped. Any ideas how to get the figures to appear much earlier in the document, where they are approximately first mentioned in the .tex file?

  • Also see <tex.stackexchange.com/questions/2275/…> – Will Robertson Feb 18 '11 at 0:35
  • 18
    If one figure or table has a width or height greater than the current textwidth or height, itself and all following will move to the end of the chapter/section – user2478 Feb 18 '11 at 8:04
  • Perhaps use the smallest and simplest figures that convey the required information, so that you don't distract the reader's eye. Pack a punch in a tiny space, keeping your figure easy to scan by removing any unnecessary details. Figures in the flow of the text are easiest for the reader to absorb. – Benjamin McKay Feb 25 '13 at 18:52
38

Note that this has been mentioned in a few places already. Here is a summary:

If you really want them to stay in place, you could just not put them in Floats. Then you can use either the caption or the capt-of package to add a caption to the figure.

However, I think that the most accepted method is to use the placeins package to have your floats placed in the section they appear in. You can also define \FloatBarriers to decide where floats should not go past.

Playing with the size of the figure, even for a couple of points, can also make a great difference in the placement while not changing much of the visual aspect.

  • +1: While placeins doesn't stop figure migrating to be on their own page (because almost nothing short of resizing them can). It forced them to only migrate so far. Thus locking them down to there section (or subsection see tex.stackexchange.com/questions/118662/…). Thus solving many issues. Its almost always preferable (for my work at least) to have them be anywhere closer than the end of the document. – Lyndon White Oct 22 '14 at 3:48
60

Your figures are most likely too large and/or you tell LaTeX to place them at a position where they don't fit. So they are are pushed to the last position were they finally do: the end of the document.

Adding restrictions like [t] (top) or [h] (here, LaTeX has a habit of refusing it) doesn't help, but makes things worse! Actually removing all of that restrictions might help. There is a good reason why this argument to figure is optional! If you are using it add at least p so LaTeX can do float-only pages.

To fix this you can allow more space for floats (figure and table) alike by redefining one or more of the following macros. The ...fraction ones define the fraction of the page with is allowed to be used on top or bottom etc. The ...number ones define the maximum number of floats at these positions. The values below are examples from this TeX FAQ.

\renewcommand{\topfraction}{.85}
\renewcommand{\bottomfraction}{.7}
\renewcommand{\textfraction}{.15}
\renewcommand{\floatpagefraction}{.66}
\renewcommand{\dbltopfraction}{.66}
\renewcommand{\dblfloatpagefraction}{.66}
\setcounter{topnumber}{9}
\setcounter{bottomnumber}{9}
\setcounter{totalnumber}{20}
\setcounter{dbltopnumber}{9}

I wouldn't recommend to change your figures to non-floating ones because this gives bad layout.

  • 7
    Thanks. I had [t] on a figure that was too big. Removing [t] or changing it to [tp] worked for me. – geometrikal Aug 12 '14 at 2:53
  • 4
    I had the exact same problem. I have the habit of adding [h] or [h!] to all my figures. Removing it fixed the issue for me and stopped pushing my floats to the end of the chapter. – Ahmed El Bokl Mar 19 '15 at 0:33
  • [!htbp] works pretty well if you put it on every figure without having to think. You can always remove the p from small figures if they get placed on their own page. – WetlabStudent Jan 15 '17 at 12:33
  • 1
    I just replaced [h] with [p] and all works great now. Thanks. – Nikos Feb 21 '17 at 23:26
  • 1
    Worked for me - removing [h] fixed the problem. – axel22 Apr 21 '17 at 23:26
25

Start with appropriate placement parameters for your float objects.

\begin{figure}[!ht]
% figure content
\end{figure}

The exclamation mark overwrites the internal values introduced by Martin and makes LaTeX "try harder" to place the float at the earliest possible place. It is documented in Appendix C.9 of the Lamport book.

  • 1
    Neither !h or t will do any good when the figure is larger then 1-\textfraction or \topfraction. IMHO restricting a figure causes this issue more often then fixing them. – Martin Scharrer Feb 18 '11 at 10:07
  • 5
    There was no talk of "!h or t", but of [!ht]. One single parameter is never good. And a figure with that size should be placed on its own float page by using [!p] as placement parameter. – Thorsten Donig Feb 18 '11 at 10:33
  • Thanks man, this solution works great, I though i were screwed !! – Noor May 10 '13 at 13:56
  • Thank you @ThorstenDonig! I was struggling with this for some time and solved it with a single character '!'. – Carser May 7 '14 at 19:43
5

As @Mortimer said, you can use \FloatBarrier from package placeins to add a barrier for figures, preventing the figures from going past that point.

However, this may inevitably create empty spaces in the page where you put the FloatBarrier. To fix this, use the package afterpage to create a smart placement of the \FloatBarrier command.

In short, instead of \FloatBarrier, use

\afterpage{\FloatBarrier}

This will automatically place the \FloatBarrier command immediately after the current page finishes, thus preventing any white space on the current page.

  • 1
    Don't forget to mention that \usepackage{afterpage} is required. – koppor Jul 20 '15 at 8:13
  • 1
    \afterpage{\clearpage} should achieve the same effect – koppor Jul 20 '15 at 12:07
  • 1
    Note that the float will be output automatically (without needing the rather fragile \afterpage if the float has not been prevented from being on a float page (by use of an option such as [ht]) and if it is big enough to be output as a float page (\floatpagefraction) so if \floatpagefraction is set correctly \afterpage{\clearpage} should not normally be needed. – David Carlisle Mar 31 '16 at 9:51
0

I solved this problem by using \vspace{-20pt} after and before the caption to remove vertical space as shown:

\begin{figure}[t!]
\centering
\vspace{-20pt}
\centering\includegraphics[scale=0.8]{myfigure.eps}
\vspace{-10pt}
\caption{my caption}
\vspace{-20pt}
\label{fig:myfigure}
\end{figure}
  • 5
    That is really not a good solution. It could have side-effects when you least expect them, especially if other aspects of your document change. I wouldn't recommend others use this approach as it is, at best, covering something up rather than solving it and, at worst, will cause far more problems than it solves. – cfr Dec 24 '14 at 2:54
0

The best way is clearly to use the \afterpage, pretty simple and worked perfectly fine for me after having issues with the brackets methods [!hf] and other useless methods...

  • 3
    This answer is simply wrong, sorry. [!hf] is a syntax error so wouldn't be expected to be useful and "use \afterpage" doesn't give any hint on how that command could be used to control floats (some possible mechanisms to control floats could use \afterpage in combination with other commands but it is almost never the recommended way) (I wrote afterpage and I'd not use it for that in a real document, most likely. – David Carlisle Mar 31 '16 at 9:45
0

I had this same problem. Replacing [t] with [htbp] helped:

\begin{table*}[htbp]
  • h - where the table is declared (here)
  • t - at the top of the page
  • b - at the bottom of the page
  • p - on a dedicated page of floats
  • 1
    Why do you use table*? – Werner Nov 19 '16 at 6:12
  • 2
    Because some documents are two-columned. – Jongwook Choi Nov 19 '16 at 11:09
  • 2
    To future readers: the table* environment, when used in twocolumn mode, won’t honor the h and b position specifiers; if this may sound obvious for h, perhaps it is not for b (when used in onecolumn mode, table* is effectively equivalent to table). – GuM May 12 '17 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.